Welcome Help Homepage

Rohde & Schwarz

Welcome to RSUPL LabVIEW instrument driver help

This help system is intended to provide you with all the information that is necessary for remote control of the R&S device via instrument driver. Please use the navigation tools to the left or directly access the main chapters:

Why Instrument drivers?

Supported Environments

Supported Interfaces

What's new

Getting started and Examples

Instrument Driver Tree structure

Alphabetical list of VIs

Contact

Install and how to use this help

We also invite you to find out what's new in the current revision of the instrument driver.

If you have any questions or comments, please contact your partners at Rohde & Schwarz and give us your feedback.

Trade names are trademarks of the owners

Copyright © 2004 Rohde & Schwarz GmbH & Co. KG
Last updated: August 25, 2005


Instrument Drivers

Why Instrument drivers?

Many Rohde & Schwarz customers prefer the graphical programming languages LabVIEW from National Instruments or VEE from Agilent when writing applications for T&M equipment. Quite often, C-based LabWindows/CVI from National Instruments and Visual Basic or Visual C++ from Microsoft/ Borland are also used.

As a service, Rohde & Schwarz provides software device drivers free of charge for all these programming languages. All recent T&M equipment is supported, and demo programs are also often available.

Why a device driver?

Writing an application can take a lot of time. But writing the application is not the end of the story, since the T&M device must also be driven. That is not so simple with complex equipment, since just the description of the command set may comprise several hundred pages. Applying yourself to this task can be quite time-consuming. Which is why Rohde & Schwarz provides ready-to-use software device drivers for all major interfaces, relieving designers of these efforts to a great extent. You no longer have to search through manuals looking for commands; this has already been done when developing the driver.


Supported Environments

You can use this driver with Windows 9x/NT/2000/XP and installed LabVIEW 6i or later.


Supported Interfaces

Which interfaces are supported?

Current revision of instrument driver supports interfaces:

  • IEEE 488.2 (IEC-625, GPIB)
  • RS 232C


What's new

What's New in this Revision

This help describes revision "Rev 3.1.2, 11/2007, LV6.1" of the instrument driver. The major new features and revision history are listed below.

----- Rev. 3.1.2, November 2007 by Jiri Kominek -----

* Fixed decimal separator in:
- RSUPL Data Write Block.vi
- RSUPL Config Analyzer Func DC.vi
* Added RSUPL Config Analyzer Single Filter Sel.vi

----- Rev. 3.1.1, August 2005 by Jiri Kominek -----

* General changes/corrections:
- Fixed palette menu

* Bugfixes:
- RSUPL Error Query.vi
- RSUPL Error Query (Multiple).vi

* Additions:
- none -

* deleted VIs:
- none -

* new VIs:
- none -

----- Rev. 3.1, May 2004 by Jiri Kominek -----

* General changes/corrections:
- renamed VIs with '/' in the name:
  - RSUPL Config Save/Recall Setup.vi to RSUPL Config Save Recall Setup.vi
  - RSUPL Config Analyzer Func RMS S/N.vi to RSUPL Config Analyzer Func RMS S N.vi

* Bugfixes:
- none -

* Additions:
- none -

* deleted VIs:
- none -

* new VIs:
- none -

----- Rev. 3.0, August 1999 by Tobias Hermann 1GPP, Rohde & Schwarz Munich -----

* General changes/corrections:
- cluster inputs in all VIs with more than 6 inputs
- connector panes: 5x5 type
- improved code of Get* VIs (now in RSUPL_U.llb)
- improved code of Data Read Block VI

* Bugfixes:
- Config Gen Sweep Setup
fixed bugs preventing user from loading x and z axis sweep list files
- Config Analyzer Func DFD/Mod Dist/THD/THD+N/W+F/Waveform/Filt Sim VIs
fixed bug issuing wrong UNIT command when only CH2 active in analyzer
- Config Analyzer Func RMS/Peak/QPeak VIs
fixed bug erroneously issuing UNIT commands in S/N Sequence mode

* Additions:
- none -

* deleted VIs:
- none -

* new VIs:
- none -

----- Rev. 2.0, April 1998 by Tobias Hermann 1GP2, Rohde & Schwarz Munich -----

* General changes/corrections:
- Reference Level must not be zero - changed default value in all affected VIs

* Bugfixes:
- Cfg Gen Func Sine VI
A25 Generator: issue equalizer file load command only if "Equalization" == "on" (added Case Structure)
- Cfg Analyzer Analog Setup VI
added synchronisation command after instrument selection (wait for analyzer offset calibration)
- Cfg Analyzer Trig VI
renamed Start Condition 9/10 to "Freq Fast Ch1/2" (changed Front Panel and Description)
- Cfg Analyzer Func RMS S/N VI, Cfg Analyzer Func FFT VI
issue notch filter freq "FIX" command only if "Notch Gain" != "off" (added Case Structure)
- Cfg Analyzer Func Peak VI, Cfg Analyzer Func W+F VI
added cases A22/A110 (Peak/W+F not supported in A110)
- Cfg Analyzer Func QPeak VI
issue notch filter freq "FIX" command only if "Notch Gain" != "off" (added Case Structure)
added cases A22/A110 (QPeak not supported in A110)
- Cfg Analyzer Meas Inp Freq VI
added cases A22/D48 (e.g. no Sample Frequency measurement in A22 instrument)
- Data Read Block VI
read 4n+1 bytes, process 4n bytes (UPL terminates data blocks with <EOI> + <LF>)
added VISA error status check (errors in previous VIs appeared as Block Data Errors)
- Application Example VI
changed to universal analog generator (to make it run on models without option UPL-B2)
removed trigger VIs (not necessary for generator functions)

* Additions:
- Get Analyzer Mode VI
added query A22/A110 and "instr mode" output (for Cfg Analyzer Func Peak/QPeak/W+F VIs)
- Config Instr Display
added control for disabling the cursor readout in the instrument's graphic display (enhances measurement speed)

* deleted VIs:
- Screen Hardcopy is no longer supported by the driver (not of much use in remote mode)

* new VIs:
- Meas Dual Channel VI [Data VIs]
Reads the results from both channels at once (added for better consistency of the driver concept)
- Set Freq & Level VI [Action VIs]
Directly accesses the generator's frequency and/or level controls without overhead (useful for fast measurement loops controlled from LabVIEW)
- Config Instr Audio Monitor VI	[Config Instrument VIs]
Configures the instrument's Audio Monitor (Option UPL-B6)
- Config Instr Sense [Config Instrument VIs]
Allows for disabling the instrument's sense systems 1 (Analyzer Function), 2 (Input Level) and 3 (Input Frequency) (enhances measurement speed)


Getting started and Examples

Getting Started

If you want to use this driver as a standard LabVIEW driver, please copy manually the content of ~VXIpnp\GWinNt\rsupl directory into your LabVIEW directory (~LabVIEW\instr.lib\rsupl\). The driver will then be directly accessible from the LabVIEW Instrument Driver function pallete menu.

Examples

To get started with the driver please open RSUPL Getting Started.vi. Select the appropriate Instrument Descriptor and run the VI. For how to use the driver, see in VIs from group 'Application Examples':

RSUPL Getting Started.vi

RSUPL Application Example.vi


Tree structure

RSUPL VI Tree

This page shows structure of the instrument driver.

    RSUPL Initialize
    Application Functions
      RSUPL Application Example
      RSUPL Getting Started
    Configuration Functions
      Generator Config
        RSUPL Config Gen Analog Setup
        RSUPL Config Gen Digital Setup
        RSUPL Config Gen Digital Sync
        RSUPL Config Gen Digital Protocol
        RSUPL Config Gen Func Sine
        RSUPL Config Gen Func Multi
        RSUPL Config Gen Func Burst
        RSUPL Config Gen Func Burst 2
        RSUPL Config Gen Func Modul Distortion
        RSUPL Config Gen Func Diff Freq Distortion
        RSUPL Config Gen Func Random
        RSUPL Config Gen Func Arbitrary
        RSUPL Config Gen Func Polarity
        RSUPL Config Gen Sweep Setup
        RSUPL Config Gen Sweep Freq
        RSUPL Config Gen Sweep Level
        RSUPL Config Gen Sweep On Time
        RSUPL Config Gen Sweep Interval
      Analyzer Config
        RSUPL Config Analyzer Analog Setup
        RSUPL Config Analyzer Digital Setup
        RSUPL Config Analyzer Post FFT
        RSUPL Config Analyzer Settl
        RSUPL Config Analyzer Trig
        RSUPL Config Analyzer Filter User
        RSUPL Config Analyzer Filter Sel
        RSUPL Config Analyzer Limit
        RSUPL Config Analyzer Protocol Anl
        RSUPL Config Analyzer Func RMS S N
        RSUPL Config Analyzer Func RMS Sel
        RSUPL Config Analyzer Func RMS Sweep
        RSUPL Config Analyzer Func Peak
        RSUPL Config Analyzer Func Quasi Peak
        RSUPL Config Analyzer Func DC
        RSUPL Config Analyzer Func THD
        RSUPL Config Analyzer Func THD + Noise
        RSUPL Config Analyzer Func Mod Dist
        RSUPL Config Analyzer Func Diff Freq Dist
        RSUPL Config Analyzer Func Wow & Flutter
        RSUPL Config Analyzer Func Polarity
        RSUPL Config Analyzer Func FFT
        RSUPL Config Analyzer Func Waveform
        RSUPL Config Analyzer Func Filt Sim
        RSUPL Config Analyzer Func Protocol
      System Config
        RSUPL Config Save Recall Setup
        RSUPL Config Instr Ver
        RSUPL Config Instr Opt
        RSUPL Config Instr Trig
        RSUPL Config Instr Audio Monitor
        RSUPL Config Instr Calibr
        RSUPL Config Instr Display
        RSUPL Config Instr Sense
        RSUPL Config Store Data
    Action/Status Functions
      RSUPL Set Freq & Level
      RSUPL Send Trig
      RSUPL Step
      RSUPL Abort
      RSUPL Operation Complete
    Data Functions
      RSUPL Data Store Del
      RSUPL Data Store Copy
      RSUPL Data Store Dir
      RSUPL Data Read Block
      RSUPL Data Write Block
      RSUPL Meas Single Ch
      RSUPL Meas Dual Ch
      RSUPL Meas Protocol
      RSUPL Meas Limit
    Utility Functions
      RSUPL Reset
      RSUPL Self Test
      RSUPL Error Query
      RSUPL Error Message
      RSUPL Revision Query
    RSUPL Close


RSUPL Initialize

This VI passes the addressing information in the instrument decriptor to the Instr Open VI and returns the instrument ID. You can optionally reset the instrument by setting the front panel reset control. You must run this VI before using any of the instrument driver VIs for this instrument.

Notes:
(1) The 'instrument descriptor' string for an instrument connected to the PC's serial interface is "ASRLn" where n is the number of the COM port.
(2) If you plan to use this driver with the serial interface, be sure to change the default "COM2 Parameter" settings in the instrument's Option panel as follows:
- Baud Rate: 9600 Baud
- Parity: NONE
- Data Bits: 8
- Stop Bits: 1
- Handshake: RTS/CTS (null-modem cable suitable for hardware handshake required)
These settings allow for binary block data transfer. If you don't need binary transfers, you are free to use any other settings.
You might want to specify a higher baud rate (up to 56000 Baud) if your PC supports it. Edit the constants in the Serial Interface case structure on the block diagram of this VI if you want to apply any changes.

String instrument descriptor (GPIB::) (string)
A string that uniquely identifies the instrument to open or initialize. The grammar for the instrument descriptor is shown below. Parameters are shown in lower-case and optional parameters are shown in square brackets ([]).

Default Value: GPIB::

GPIB - GPIB[bd]::prim addr[::sec addr]
VXI - VXI[bd]::logical addr
GPIB-VXI - GPIB-VXI[bd][::prim addr]::logical addr

Parameters (default value):
bd - GPIB board (0)
prim addr - GPIB primary address (1)
sec addr - GPIB secondary address (none)
logical addr - VXI logical address

EXAMPLE: A GPIB instrument on GPIB board 0, at primary address 5, and no secondary addressing.

GPIB::5
Boolean reset (reset:T) (TF)
Selects whether or not to reset the instrument.

Valid Range:
F - don't reset
T - reset

Default Value: T - reset
Boolean ID query (check:T) (TF)
Selects whether or not to check the instrument's ID to be sure the instrument is the type expected.

Valid Range:
F - don't check
T - check

Default Value: T - check
Refnum VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum VISA session (for class)
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


RSUPL Application Example

This VI demonstrates higher-level approach to the instrument driver. It performs a set of operations which completely configure the instrument to satisfy the user's needs.
This VI should be used as an example for building applications using this instrument driver. In particular, note the use of the driver VIs' control clusters utilizing hidden front panel controls and the Bundle By Name function.

This VI performs the following operations:

1) configures the internal universal analog generator
2) sets up the generator function (sine)
3) reads out the instrument's error queue.

RSUPL Application Example.vi

Boolean channel (1:F) (TF)
This control selects the active channels of the digital generator on which the generated signal will be output. The signal will be available on the XLR conector of the corresponding channel.

Valid Range:
F - channel 1 (default)
F - channel 2
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
DBL frequency in Hz (1000.0) (DBL)
This control specifies the frequency of the output sinewave.

Valid Range: 10.0 Hz to 110 kHz

Default Value: 1000.0 Hz
DBL level in V (0.5) (DBL)
This control sets the level of the output sine waveform.

Valid Range: 0.0 to 1.0 FS

Default Value: 0.5 FS
DBL dc offset in V (0.0) (DBL)
This control sets the level of the output sine waveform.

Valid Range: -1.0 to 1.0 FS

Default Value: 0.0 FS
Cluster Output Mode Output Mode Cluster

Contains the following controls:
- Channel selection
- Output selection
- Balanced Output Impedance.
I32 | Channel (1:1) (I32) This control sets the active channels of the analog generator. Valid Range: 0 - off (default) 1 - channel 1 2 - channel 2 3 - 2=1, identical signal on both channels Notes: (1) The deactivated channel is internally terminated with the internal impedance set.
Boolean | Output (unbal:F) (TF) This control sets the outpu coupling of the analog output signal. Valid Range: F - unbalanced (default) T - balanced Notes: (1) When set to unbalanced, the maximum output level is 10 V, the output impedance is fixed: 5.0 Ohms. (2) When set to balanced, the maximum output level is 20 V. (3) When set to balanced, the output impedance can be set via the control 'output impedance' to 10, 200 or 600 Ohms.
I32 | Impedance (10 Ohms:0) (I32) This control sets the output impedance of the balanced output. Valid Range: 0 - 10 Ohms (default) 1 - 200 Ohms 2 - 600 Ohms Notes: (1) This control has no effect if the output is set to unbalanced, the output impedance is generally 5.0 Ohms.
Cluster Frequency
Boolean | freq offset (off:F) (TF) This control turns the frequency offset on or off. Valid Range: F - off (default) T - on Notes: (1) This control is active only in analog generator mode. (2) If on, frequency offset of +0.1% is applied.
DBL | frequency (1000.0) (DBL) This control sets the sinewave frequency. Valid Range: 10.0 Hz to 110.0 kHz Default Value: 1000.0
I32 | freq unit (Hz:0) (I32) This control sets the sinewave frequency unit. Valid Range: 0 - Hz (default) 1 - kHz 2 - dHz 3 - dkHz 4 - f/fr 5 - d%Hz 6 - Toct 7 - Oct 8 - Dec
Cluster DC Offset
Boolean | dc offset (off:F) (TF) This control turns the dc offset on or off. Valid Range: F - off (default) T - on
DBL | dc offset value (0.0) (DBL) This control sets the dc offset value. Valid Range: -10.0 to 10.0 V Default Value: 0.0 Notes: (1) This control has no effect if the dc offset is off.
I32 | dc offset unit (V:0) (I32) This control sets the dc offset unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - dBr 12 - FS 13 - %FS 14 - dBFS 15 - LSBs 16 - d% 17 - bits Notes: (1) This control has no effect if the dc offset is off.
Cluster Level
DBL | level (1.0) (DBL) This control sets the amplitude of the output sinewave. Valid Range: digital: 0.0 to 1.0 FS (audio data mode) 0.0 to 5.0 UI (jitter mode) 0.0 to 7.071 Vrms (common mode) analog: 0.0 to 10.0 Vrms for unbalanced output 0.0 to 20.0 Vrms for balanced output Default Value: 1.0 Notes: (1) Use RSUPL Config Gen Analog Setup.vi or RSUPL Config Gen Digital Setup.vi to set the level limit value.
I32 | level unit (V:0) (I32) This control sets the amplitude unit of the output sinewave. Valid Range: analog and digital common mode 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - Vpp 12 - mVpp 13 - uVpp 14 - dBr digital audio data mode 14 - dBr 15 - FS 16 - %FS 17 - dBFS 18 - LSBs 19 - d% 20 - bits digital jitter mode 14 - dBr 21 - UI 22 - %UI 23 - dBUI 24 - ppm 25 - ns 26 - UIr


RSUPL Getting Started

The Getting Started VI is a complete example of how to initialize, configure, output a sine waveform, and then close the instrument.

This VI performs the following operations:

1) selects desired interface for communication with the instrument
2) initializes the instrument
3) invokes the RSUPL Application Example VI (see there)
4) recovers any errors
5) closes the instrument.

RSUPL Getting Started.vi

Boolean channel (1:F) (TF)
This control selects the active channels of the digital generator on which the generated signal will be output. The signal will be available on the XLR conector of the corresponding channel.

Valid Range:
F - channel 1 (default)
F - channel 2
DBL frequency in Hz (1000.0) (DBL)
This control specifies the frequency of the output sinewave.

Valid Range: 10.0 Hz to 110 kHz

Default Value: 1000.0 Hz
DBL level in V (0.5) (DBL)
This control sets the level of the output sine waveform.

Valid Range: 0.0 to 10.0 V

Default Value: 0.5 V

Notes:
1) The valid range for this control is influenced by the Offset Voltage setting. Specifying a DC offset lowers the available AC output swing.
DBL dc offset in V (0.0) (DBL)
This control sets the dc offset level of the output sine waveform.

Valid Range: -5.0 to 5.0 V

Default Value: 0.0 V
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Boolean Reset (reset:T) (TF)
Selects whether or not to reset the instrument.

Valid Range:
F - don't reset
T - reset

Default Value:
T - reset
String instrument descriptor (GPIB::) (string)
A string that uniquely identifies the instrument to open or initialize. The grammar for the instrument descriptor is shown below. Parameters are shown in lower-case and optional parameters are shown in square brackets ([]).

Default Value: GPIB::

GPIB - GPIB[bd]::prim addr[::sec addr]
VXI - VXI[bd]::logical addr
GPIB-VXI - GPIB-VXI[bd][::prim addr]::logical addr

Parameters (default value):
bd - GPIB board (0)
prim addr - GPIB primary address (1)
sec addr - GPIB secondary address (none)
logical addr - VXI logical address

EXAMPLE: A GPIB instrument on GPIB board 0, at primary address 5, and no secondary addressing.

GPIB::5

Notes:
(1) The 'instrument descriptor' string for an instrument connected to the PC's serial interface is "ASRLn" where n is the number of the COM port.


RSUPL Config Gen Analog Setup

This VI configures the following basic settings of the analog generator:
- active channels
- output coupling
- output impedance
- output level limit
- output level limit unit
- reference frequency
- reference level

RSUPL Config Gen Analog Setup.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Reference Settings Reference Settings Cluster

Contains the following controls:
- reference frequency
- reference level value
- reference level unit.
DBL | ref freq in Hz (1000.00) (DBL) This control sets the reference frequency in Hz. Valid Range: 0.001 to 1.0e6 Hz Default Value: 1000.00 Notes: (1) A change of the reference frequency causes all reference-related frequency inputs to change. (2) The relative frequency of the generator signal is retained. (3) Varying the reference frequency may shift the fundamental of a distortion spectrum set by means of multisine without the harmonics having to be recalculated and set again by the user, by way of example.
DBL | reference level (1.0) (DBL) This control sets the reference level. Valid Range: 10.0 nFS to 1.0 FS Default Value: 0.001 Notes: (1) A change of the reference level causes all reference-related voltage inputs to change. (2) The relative voltage of the generator is retained. (3) Varying the reference voltage may e.g. shift a level sweep defined by relative start and stop levels by a constant gain factor.
I32 | ref level unit (V:0) (I32) This control sets the reference level unit. Valid Range: 0 - V 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - UI 6 - %UI 7 - dBUI 8 - ppm 9 - ns 10 - UIr 11 - dBr 12 - FS (default) 13 - %FS 14 - dBFS 15 - LSBs 16 - d% 17 - bits
Cluster Level Limit Level Limit Cluster

Contains the following controls:
- Level Limit value
- Level Limit unit.
DBL | level limit (10.0) (DBL) This control sets the max output level limit. It prevents the inadvertent entry of exceeded voltage values. Valid Range: 0.0 to 10.0 V for unbalanced output 0.0 to 20.0 V for balanced output Default Value: 12.0 V Notes: (1) The RMS value for sinewave signals is entered, i.e. the peak value of the level limit is sqrt(2) times higher.
I32 | level lim unit (V:0) (I32) This control sets the level limit unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu
Cluster Output Mode Output Mode Cluster

Contains the following controls:
- Channel selection
- Output selection
- Balanced Output Impedance.
I32 | Channel (1:1) (I32) This control sets the active channels of the analog generator. Valid Range: 0 - off (default) 1 - channel 1 2 - channel 2 3 - 2=1, identical signal on both channels Notes: (1) The deactivated channel is internally terminated with the internal impedance set.
Boolean | Output (unbal:F) (TF) This control sets the outpu coupling of the analog output signal. Valid Range: F - unbalanced (default) T - balanced Notes: (1) When set to unbalanced, the maximum output level is 10 V, the output impedance is fixed: 5.0 Ohms. (2) When set to balanced, the maximum output level is 20 V. (3) When set to balanced, the output impedance can be set via the control 'output impedance' to 10, 200 or 600 Ohms.
I32 | Impedance (10 Ohms:0) (I32) This control sets the output impedance of the balanced output. Valid Range: 0 - 10 Ohms (default) 1 - 200 Ohms 2 - 600 Ohms Notes: (1) This control has no effect if the output is set to unbalanced, the output impedance is generally 5.0 Ohms.


RSUPL Config Gen Digital Setup

This VI configures the following basic settings of the digital generator:

(Only available with option B2 installed.)

- source mode
- active channels
- audio bits
- unbalanced output connector coupling
- phase offset
- output level limit
- output level limit unit
- reference level
- reference level unit
- reference frequency
- unbalanced level
- unbalanced level unit
- cable simulator

RSUPL Config Gen Digital Setup.vi

I32 Src Mode (audio:0) (I32)
This control sets the signal that is to be generated at the digital interfaces.

Valid Range:
0 - audio data (default)
1 - jitter
2 - phase
3 - common mode

Notes:
(1) When set to audio data, digital audio data without jitter will be generated.
(2) When set to jitter, the audio data is superimposed an analog jitter signal. All frequency and level settings refer to the jitter signal, the audio data remain constant.
(3) When set to phase, it is similar to jitter, however, the frame phase of the audio data stream to the REF output (rear of the instrument) can be set. See the Operating Manual for more information.
(4) When set to common mode, the audio data stream is superimposed by an analog signal symmetrically on both lines of the XLR connector. All frequency and level settings refer to the analog common signal, the audio data remain constant.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Output Mode Output Mode Control Cluster

Contains the following controls:
- channel
- audio bits
- unbalanced output selector
- cable simulator.
I32 | Channel (1:1) (I32) This control sets the active channels of the digital generator. Valid Range: 0 - off (default) 1 - channel 1 2 - channel 2 3 - 2=1, identical signal on both channels Notes: (1) This control has no effect if the control Src Mode is set to 'jitter' or 'common mode'.
Boolean | Unbalanced Out (audio out:F) (TF) This control sets the coupling of the unbalanced output. Valid Range: F - audio out (default) T - audio in Notes: (1) When set to audio out, the generated audio data are applied (also to BAL (XLR) and optical output). (2) When set to audio in, the digital audio data received (by the UNBAL or BAL input) are applied (front panel). E.g. an oscilloscope for observing the input signal may be connected here.
Boolean | Cable Simulator (off:F) (TF) This control turns the cable simulation on or off. Valid Range: F - off (default) T - on Notes: (1) When the simulation is on, a cable length of approx. 100 m is simulated at the UNBAL (BNC) or BAL (XLR) outputs. (2) The cable simulation is effective even if the AUDIO IN signal is applied to the UNBAL (BNC) output.
I32 | Audio Bits (20) (I32) This control sets the word width of generated audio samples in bits. Valid Range: 8 to 24 Default Value: 20 Notes: (1) If the word width is reduced, the audio sample values are rounded to the given word width.
Cluster Level Control Level Control Cluster

Contains the following controls:
- unbal level value
- unbal level unit.
DBL | unbal level (1.0) (DBL) This control sets the output voltage of the digital signal at the UNBAL (BNC) interface. Valid Range: 0.0 to 2.125 V Default Value: 0.0 Notes: (1) The value passed via this control specifies a peak-to-peak voltage with termination by the rated impedance 75 Ohms. With an open circuit the voltage is twice as high.
I32 | unbal level unit (V:0) (I32) This control sets the unbalanced level unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu
Cluster Phase Offset Phase Offset Cluster

Contains the following controls:
- phase offset value
- phase offset unit.
DBL | Phase Offset (0.0) (DBL) This control sets the frame phase between the digital audio output and the REF output (rear) in the units of UI. Valid Range: -64.0 to 64.0 UI (corresponds to -180 to 180 degrees) Default Value: 0.0 Notes: (1) This control has an effect only in 'phase' source mode.
I32 | phase offset unit (UI:0) (I32) This control sets the phase offset's unit. Valid Range: 0 - UI (default) 1 - %FRM 2 - degFRM 3 - ns
Cluster Reference Settings Reference Settings Cluster

Contains the following controls:
- reference frequency
- reference level value
- reference level unit.
DBL | ref freq in Hz (1000.00) (DBL) This control sets the reference frequency in Hz. Valid Range: 0.001 to 1.0e6 Hz Default Value: 1000.00 Notes: (1) A change of the reference frequency causes all reference-related frequency inputs to change. (2) The relative frequency of the generator signal is retained. (3) Varying the reference frequency may shift the fundamental of a distortion spectrum set by means of multisine without the harmonics having to be recalculated and set again by the user, by way of example.
DBL | reference level (1.0) (DBL) This control sets the reference level. Valid Range: 10.0 nFS to 1.0 FS Default Value: 0.001 Notes: (1) A change of the reference level causes all reference-related voltage inputs to change. (2) The relative voltage of the generator is retained. (3) Varying the reference voltage may e.g. shift a level sweep defined by relative start and stop levels by a constant gain factor.
I32 | ref level unit (FS:12) (I32) This control sets the reference level unit. Valid Range: 0 - V 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - UI 6 - %UI 7 - dBUI 8 - ppm 9 - ns 10 - UIr 11 - dBr 12 - FS (default) 13 - %FS 14 - dBFS 15 - LSBs 16 - d% 17 - bits
Cluster Level Limit Level Limit Cluster

Contains the following controls:
- Level Limit value
- Level Limit unit.
DBL | level limit (1.0) (DBL) This control sets the output level limit of the digitally coded analog signal. Valid Range: 0.0 to 1.0 FS Default Value: 0.0 FS Notes: (1) This control has an effect only in audio data and phase source modes.
I32 | level limit unit (FS:1) (I32) This control sets the level limit unit. Valid Range: 0 - dBr 1 - FS (default) 2 - %FS 3 - dBFS 4 - LSBs 5 - d% 6 - bits Notes: (1) This control has an effect only in 'audio data' and 'phase source' modes.


RSUPL Config Gen Digital Sync

This VI configures the digital generator's synchronization settings:
- output synchronization source
- input synchronization source
- input synchronization mode
- sampling frequency
- synchronization signal type
- output data

RSUPL Config Gen Digital Sync.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Sync To
I32 | input sync source (generator clk:0) (I32) This control sets the input synchronization source. Valid Range: 0 - generator clock (default) 1 - sync input 2 - reference input 3 - analyzer audio input Notes: (1) If set to to analyzer audio input, the generator is synchronized to analyzer audio input signal. This option is not valid for jitter and phase generator source modes. (2) If set to generator clock, the generator is synchronized to internal clock generator. (3) If set to reference input, the generator is synchronized to the REF IN input signal (XLR socket on the rear panel of the instrument). This option is not valid for phase generator source mode. (4) If set to sync input, the generator is synchronized to the SYNC IN input signal (BNC connector on the rear panel of the instrument). This option is not valid for phase and jitter generator source modes.
I32 | sampling frequency (48kHz:2) (I32) This control sets the output clock rate. Valid Range: 0 - 32 kHz 1 - 44.1 kHz 2 - 48 kHz (default) 3 - external 4 - value: Notes: (1) Options 32, 44.1 or 48 kHz can be set only if the control Input Sync Source is set to 'generator clock' or 'sync in'. (2) If set to 'value:', use control Sampling Freq in Hz to specify the exact sampling frequency. This option is valid only with the control Input Sync Source set to 'generator clock'. (3) If set to external, use control 'sampling freq value in Hz' to specify the exact sampling frequency. This option is valid only with the controls 'input sync source' is set to sync in and 'input source mode' set to word clock or inv word clock (the generator is synchronized via the SYNC IN female connector to a word clock signal).
DBL | sampling freq in Hz (48000.0) (DBL) This control specifies the sample frequency of the generator. Valid Range: 27000.0 to 55000.0 Hz Default Value: 48000.0 Hz Notes: (1) This control is active only if the control 'sampling frequency' is set to value: or external.
I32 | input sync mode (word clk:0) (I32) This control specifies the synchronization mode of the sampling frequency. Valid Range: 0 - word clock (default) 1 - inverted word clk 2 - 1024 kHz 3 - video 50 4 - video 60 Notes: (1) This control is active only if the input sync source is set to sync in. (2) If set to word clock, the sampling frequency is synchronized to the word clock signal at SYNC input. (3) If set to inv word clock, the sampling frequency is synchronized to the inverted word clock signal at SYNC input. (4) If set to 1024kHz, the sampling frequency is synchronized to a 1024kHz reference signal. (5) If set to video 50, the sampling frequency is synchronized to a video frequency of 50Hz (Europe). (5) If set to video 60, the sampling frequency is synchronized to a video frequency of 60Hz (USA).
Cluster Sync Out
I32 | out sync source (audio input:0) (I32) This control specifies which clock signal is connected to the SYNC OUT output (BNC female connector on the rear of the instrument). Valid Range: 0 - audio input (default) 1 - generator clock 2 - reference input 3 - internal PLL Notes: (1) Option generator clock can only be set with input synchronization source set to generator clock. (2) If set to audio input, the digital audio input on the front panel of the instrument is connected to SYNC OUT. (3) If set to reference input, the XLR female connector on the rear panel is connected to SYNC OUT. (4) If set to internal PLL, the signal from the internal synchronization PLL (e.g. input signal with eliminated jitter) is connected to SYNC OUT.
Boolean | sync signal type (word clk:F) (TF) This control sets the type of the SYNC OUT signal. Valid Range: F - word clock (default) T - biphase clock Notes: (1) If set to word clock, the SYNC OUT signal is output at the sample frequency. (2) If set to biphase clock, the SYNC OUT signal is output at 128 times the sample frequency.
Cluster Reference Out
I32 ref out (audio input:0) (I32)
This control specifies which signal is connected to the REF OUT output (XLR female connector on the rear panel of the instrument).

Valid Range:
0 - audio input (default)
1 - audio in rear clk
2 - audio out
3 - ref generator

Notes:
(1) audio in rear clock and ref generator option are only possible with input sync source set to generator clock.
(2) If set to audio in, the buffered audio input is connected to the REF OUT.
(3) If set to audio in rear clk, the audio iput signal which is relocked by the internal synchronization PLL is connected to the REF OUT.
(4) If set to audio out, the generated audio signal (same as on the front panel) is connected to the REF OUT.
(5) If set to ref generator, generated reference signal is connected to the REF OUT. To define generated reference signal (constant low or high use control 'output data').
(6) In the generator source mode set to 'phase' (via RSUPL Config Gen Digital Setup.vi), this control's only valid setting is 'ref generator'.
Boolean output data (all zero:F) (TF)
This control defines the audio data which are output at the REF OUT output (XLR female on the rear panel of the instrument).

Valid Range:
F - all zero (default)
T - all one

Notes:
(1) This control is active only if the reference out is set to ref generator.
(2) If set to all zero, all data bits are unasserted, otherwise all data bits are asserted.


RSUPL Config Gen Digital Protocol

This VI configures the following protocol definition settings:
- valid channel
- protocol mode
- chan status data left
- filename left
- chan status data right
- filename right
- user data mode
- filename user data

RSUPL Config Gen Digital Protocol.vi

Boolean valid channel (none:F) (TF)
This control sets the validity identification within the AES/EBU data stream.

Valid Range:
F - none (default)
T - 1&2

Notes:
(1) When set to 1&2, the validity bit is set in both channels, otherwise no validity bit is set.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
I32 protocol mode (off:0) (I32)
This control sets the protocol mode.

Valid Range:
0 - off (default)
1 - static
2 - enhanced
Cluster Left Channel Left Channel Cluster

Contains the following controls:
- Chan Status Data Left
- File Name Left.
I32 | chan status data left (zero:0) (I32) Sets the channel status data of the left channel. Valid Range: 0 - zero (default) 1 - AES3 2 - CRC 3 - RAW Notes: (1) In static protocol mode, only zero and RAW options are available. (2) See the User's Manual for more information.
String | file name left ("*.pgc") (abc) This control specifies a file containing channel status data of the left channel. Valid Range: all existing *.pgc files Default Value *.pgc Notes: (1) See the Users Manual for more information.
Cluster Right Channel Right Channel Cluster

Contains the following controls:
- Chan Status Data Right
- File Name Right..
I32 | chan status data right (zero:0) (I32) Sets the channel status data of the left channel. Valid Range: 0 - zero (default) 1 - AES3 2 - CRC 3 - RAW Notes: (1) In static protocol mode, only zero and RAW options are available. (2) See the User's Manual for more information.
String | file name right ("*.pgc") (abc) This control specifies a file containing channel status data of the left channel. Valid Range: all existing *.pgc files Default Value *.pgc Notes: (1) See the Users Manual for more information.
Cluster User Data User Data Cluster

Contains the following controls:
- User Data status
- File Name User Data.
Boolean | user data (zero:F) (TF) This control sets the user data generation mode. Valid Range: F - zero (default) T - file Notes: (1) If set to zero, all user bits are initialized to be 0. (2) If set to file, the user bits are output according to the definitions in the subsequent file. (3) Changing the user bits stops both the generator and the analyzer for a short time.
String | file name user data ("*.pgc") (abc) Specifies a file containing user data bits. Valid Values: all existing *.pgu files Default Value: *.pgu Notes: (1) See the User's Manual for more information.


RSUPL Config Gen Func Sine

This VI configures the following settings of the sine function generator:
- frequency offset
- dc offset
- frequency
- level
- equalizer
- dither
- low distortion generator
- probability distribution function

RSUPL Config Gen Func Sine.vi

Boolean low-distortion gen (off:F) (TF)
This control turns the low distortion generator on or off.

Valid Range:
F - off (default)
T - on

Notes:
(1) This control has an effect only in the analog generator mode.
(2) When on, the sine is generated by the low-distortion generator, otherwise it is generated by the universal generator.
(3) The low-distortion generator is available only with UPL-B1 option.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Frequency
Boolean | freq offset (off:F) (TF) This control turns the frequency offset on or off. Valid Range: F - off (default) T - on Notes: (1) This control is active only in analog generator mode. (2) If on, frequency offset of +0.1% is applied.
DBL | frequency (1000.0) (DBL) This control sets the sinewave frequency. Valid Range: 10.0 Hz to 110.0 kHz Default Value: 1000.0
I32 | freq unit (Hz:0) (I32) This control sets the sinewave frequency unit. Valid Range: 0 - Hz (default) 1 - kHz 2 - dHz 3 - dkHz 4 - f/fr 5 - d%Hz 6 - Toct 7 - Oct 8 - Dec
Cluster DC Offset
Boolean | dc offset (off:F) (TF) This control turns the dc offset on or off. Valid Range: F - off (default) T - on
DBL | dc offset value (0.0) (DBL) This control sets the dc offset value. Valid Range: -10.0 to 10.0 V Default Value: 0.0 Notes: (1) This control has no effect if the dc offset is off.
I32 | dc offset unit (V:0) (I32) This control sets the dc offset unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - dBr 12 - FS 13 - %FS 14 - dBFS 15 - LSBs 16 - d% 17 - bits Notes: (1) This control has no effect if the dc offset is off.
Cluster Level
DBL | level (1.0) (DBL) This control sets the amplitude of the output sinewave. Valid Range: digital: 0.0 to 1.0 FS (audio data mode) 0.0 to 5.0 UI (jitter mode) 0.0 to 7.071 Vrms (common mode) analog: 0.0 to 10.0 Vrms for unbalanced output 0.0 to 20.0 Vrms for balanced output Default Value: 1.0 Notes: (1) Use RSUPL Config Gen Analog Setup.vi or RSUPL Config Gen Digital Setup.vi to set the level limit value.
I32 | level unit (V:0) (I32) This control sets the amplitude unit of the output sinewave. Valid Range: analog and digital common mode 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - Vpp 12 - mVpp 13 - uVpp 14 - dBr digital audio data mode 14 - dBr 15 - FS 16 - %FS 17 - dBFS 18 - LSBs 19 - d% 20 - bits digital jitter mode 14 - dBr 21 - UI 22 - %UI 23 - dBUI 24 - ppm 25 - ns 26 - UIr
Cluster Equalizer
Boolean | equalizer (off:F) (TF) This control turns the equalizer on or off. Valid Range: F - off (default) T - on Notes: (1) When on, the equalizer table including frequency specifications and the appertaining voltage amplification factors is activated.
String | equalizer file name ("*.veq") (abc) This control specifies the equalizer filename. Valid Range: any valid dos filename with "veq" extension Default Value: *.veq Notes: (1) The specified file must exist on the instrument, otherwise an error is generated.
Cluster Dither
Boolean | dither (off:F) (TF) This control turns the dither on or off. Valid Range: F - off (default) T - on Notes: (1) When on, a noise component is superimposed on the output signal. (2) This control is active only in audio data digital mode.
DBL | dither value (0.0) (DBL) This control sets the amplitude of the noise superimposed on output signals (dither). Valid Range: 0.0 to 1.0 FS Default Value: 0.0 Notes: (1) This control has an effect only when dither is on.
I32 | dither unit (FS:1) (I32) This control sets the dither noise amplitude unit. Valid Range: 0 - dBr 1 - FS (default) 2 - %FS 3 - dBFS 4 - LSBs 5 - d% 6 - bits Notes: (1) This control has an effect only when dither is on.
I32 | pdf (gauss:0) (I32) This control specifies the amplitude distribution (probability distribution function) of the superimposed noise signal (dither). Valid Range: 0 - gauss (default) 1 - triangle 2 - rectangle Notes: (1) This control has an effect only when dither is on.


RSUPL Config Gen Func Multi

This VI generates up to 17 sine voltages superposed on each other. The available settings are:
- dc offset
- total gain in dB
- number of waveforms
- level array
- freq array
- spacing
- multisine mode

Notes:
(1) This function is available only when the generator is either in digital audio data or analog mode.

RSUPL Config Gen Func Multi.vi

DBL total gain in dB (0.0) (DBL)
This control sets an amplification factor in dB, which allows the RMS value resulting from superimposition of the single voltages to be increased or decreased.

Valid Range: -80.0 to +30.0 dB

Default Value: 0.0 dB
I32 No. of Sines (2) (I32)
This control specifies a number of sinewaves to be generated.

Valid Range: 1 to 17

Default Value: 2
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster DC Offset
Boolean | dc offset (off:F) (TF) This control turns the dc offset on or off. Valid Range: F - off (default) T - on
DBL | dc offset value (0.0) (DBL) This control sets the dc offset value. Valid Range: -10.0 to 10.0 V Default Value: 0.0 Notes: (1) This control has no effect if the dc offset is off.
I32 | dc offset unit (V:0) (I32) This control sets the dc offset unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - dBr 12 - FS 13 - %FS 14 - dBFS 15 - LSBs 16 - d% 17 - bits Notes: (1) This control has no effect if the dc offset is off.
Cluster Equalizer
Boolean | equalizer (off:F) (TF) This control turns the equalizer on or off. Valid Range: F - off (default) T - on Notes: (1) When on, the equalizer table including frequency specifications and the appertaining voltage amplification factors is activated.
String | equalizer file name ("*.veq") (abc) This control specifies the equalizer filename. Valid Range: any valid dos filename with "veq" extension Default Value: *.veq Notes: (1) The specified file must exist on the instrument, otherwise an error is generated.
Cluster Frequency
Array frequency array (DBL)
This control specifies the array of the sinewave frequencies. The size of this array must be equal to the value passed via control 'number of waveforms'.

Valid Range: spacing frequency value to 110.0 kHz

Default Value: 0.0
DBL | (DBL) This control specifies the array of the sinewave frequencies. The size of this array must be equal to the value passed via control 'number of waveforms'. Valid Range: spacing frequency value to 110.0 kHz Default Value: 0.0
I32 | freq unit (Hz:0) (I32) This control sets the sinewave frequency unit. Valid Range: 0 - Hz (default) 1 - kHz 2 - dHz 3 - dkHz 4 - f/fr 5 - d%Hz 6 - Toct 7 - Oct 8 - Dec
Boolean spacing (user def:F) (TF)
This control sets the frequency spacing mode.

Valid Range:
F - user defined (default)
T - analyzer track

Notes:
(1) Analyzer track option is valid only if the analyzer is set to FFT measurement.
(1) If set to analyzer track, the value for the FFT analysis frequency spacing is automatically adopted. This setting is ideal for an analysis with the rectangular window. If FFT is not selected on the analyzer, this setting is not valid.
(2) If set to user defined, use control 'spacing in Hz' to enter user spacing value.
DBL spacing in Hz (100.0) (DBL)
This control sets the frequency spacing value in Hz.

Valid Range:
analog: 2.9 to 10875.0 Hz
digital: internal sample freq/16384 to 10875.0 Hz

Default Value: 10.0 Hz

Notes:
(1) The entered value is corrected to the next settable value.
Cluster Amplitude
Boolean | mode (equal:F) (TF) This control selects the input mode for the individual sine amplitudes. Valid Range: F - equal amplitude (default) T - define amplitude Notes: (1) If set to equal amplitude, the same amplitude applies to each sine sine (zero index element of the amplitude array). (2) If set to define amplitude, an individual amplitude is defined for each single sine via level array control.
Array | amplitude array (DBL) This control specifies an array of sinewave amplitudes. The size of this array must be equal to the value passed via control 'number of waveforms' in define amplitudes multisine mode. Valid Range: digital: 0.0 to 1.0 FS analog: 0.0 to 12.0 V for unbalanced output 0.0 to 24.0 V for balanced output Default Value: 0.0 Notes: (1) If the control 'multisine mode' is set to equal amplitude, only the first (zeroth index element) value is used to specify the level of all sinewaves.
DBL | (DBL) This control specifies an array of sinewave amplitudes. The size of this array must be equal to the value passed via control 'number of waveforms' in define amplitudes multisine mode. Valid Range: digital: 0.0 to 1.0 FS analog: 0.0 to 12.0 V for unbalanced output 0.0 to 24.0 V for balanced output Default Value: 0.0 Notes: (1) If the control 'multisine mode' is set to equal amplitude, only the first (zeroth index element) value is used to specify the level of all sinewaves.
I32 | amplitude unit (V:0) (I32) This control sets the sinewave amplitude unit. Valid Range: analog and digital common mode 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - Vpp 12 - mVpp 13 - uVpp 14 - dBr digital audio data mode 14 - dBr 15 - FS 16 - %FS 17 - dBFS 18 - LSBs 19 - d% 20 - bits


RSUPL Config Gen Func Burst

This VI configures the sine burst function generator. A sinewave periodically varying between high and low levels is output by the instrument. The following settings are available:
- analog/digital generator switch
- dc offset
- frequency
- level
- low level
- on time value
- burst on delay value
- interval value

Notes:
(1) This function is available only when generator is either in digital audio data or analog mode.
(2) If the generator settings are modified or a measurement is (re-)started, the generator is automatically restarted and starts the interval (considering the on time delay) with high level (burst on).

RSUPL Config Gen Func Burst.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster DC Offset
Boolean | dc offset (off:F) (TF) This control turns the dc offset on or off. Valid Range: F - off (default) T - on
DBL | dc offset value (0.0) (DBL) This control sets the dc offset value. Valid Range: -10.0 to 10.0 V Default Value: 0.0 Notes: (1) This control has no effect if the dc offset is off.
I32 | dc offset unit (V:0) (I32) This control sets the dc offset unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - dBr 12 - FS 13 - %FS 14 - dBFS 15 - LSBs 16 - d% 17 - bits Notes: (1) This control has no effect if the dc offset is off.
Cluster On Time
DBL | on time (1.0) (DBL) This control sets the time during which the sine has its high level. Valid Range: 20.833 us to 60.0 sec Default Value: 1.0
DBL | level (1.0) (DBL) This control sets the amplitude of the output signal. Valid Range: digital: 0.0 to 1.0 FS (audio data mode) analog: 0.0 to 12.0 V for unbalanced output 0.0 to 24.0 V for balanced output Default Value: 1.0 Notes: (1) Use RSUPL Config Gen Analog Setup.vi or RSUPL Config Gen Analog Setup.vi to set the level limit value.
I32 | on time unit (s:0) (I32) This control sets the on time unit. Valid Range: 0 - s (default) 1 - ms 2 - us 3 - cyc 4 - kcyc 5 - Mcyc Notes: (1) Selection of one of the cycle units (cyc, kcyc, Mcyc), which are relative to frequency, results in a number of cycles - and not the burst time - remaining constant when the frequency is changed.
I32 | level unit (V:0) (I32) This control sets the level unit. Valid Range: analog: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - Vpp 12 - mVpp 13 - uVpp 14 - dBr digital audio data mode 14 - dBr 15 - FS 16 - %FS 17 - dBFS 18 - LSBs 19 - d% 20 - bits
Cluster Frequency
DBL | frequency (50.0) (DBL) This control sets the sinewave frequency. Valid Range: 10.0 Hz to 110.0 kHz Default Value: 50.0
I32 | freq unit (Hz:0) (I32) This control sets the sinewave frequency unit. Valid Range: 0 - Hz (default) 1 - kHz 2 - dHz 3 - dkHz 4 - f/fr 5 - d%Hz 6 - Toct 7 - Oct 8 - Dec
Cluster Off Time
DBL | low level (0.0) (DBL) This control sets the lower amplitude of the output signal. Valid Range: 0.0 to high level Default Value: 0.0 Notes: (1) Use RSUPL Config Gen Analog Setup.vi or RSUPL Config Gen Analog Setup.vi to set the level limit value.
DBL | interval (2.0) (DBL) This control sets the burst interval length (burst period). Valid Range: burst on time to 60.0 s Default Value: 2.0
I32 | low level unit (V:0) (I32) This control sets the low level unit. Valid Range: analog 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - Vpp 12 - mVpp 13 - uVpp 14 - V/on 15 - %on 16 - dBon 17 - dBr digital 15 - %on 16 - dBon 17 - dBr 18 - FS 19 - %FS 20 - dBFS 21 - LSBs 22 - bits Notes: (1) If unit referring to high level is selected (%on, dBon or V/on) is selected, the ratio low level/high level is always kept constant when the high level is varied.
I32 | interval unit (s:0) (I32) This control sets the interval unit. Valid Range: 0 - s (default) 1 - ms 2 - us 3 - min
Cluster On Delay
DBL | burst on delay (0.0) (DBL) This control sets the burst on delay, i.e. the burst state on is delayed by this value when the generation is either started or restarted. Valid Range: 0.0 to 60.0 sec Default Value: 0.0 Notes: (1) If the generator settings are modified or a measurement is (re-)started, the generator is automatically restarted and starts the interval (considering the on time delay) with high level (burst on).
I32 | delay unit (s:0) (I32) This control sets the burst on delay unit. Valid Range: 0 - s (default) 1 - ms 2 - us 3 - min


RSUPL Config Gen Func Burst 2

This VI configures the sine² burst function generator. A sine burst periodically starting at a phase of -90° is output by the instrument. The following settings are available:
- dc offset
- frequency
- level
- low level
- on time value
- burst on delay value
- interval value

Notes:
(1) This function is available only when generator is either in digital audio data or analog mode.
(2) If the generator settings are modified or a measurement is (re-)started, the generator is automatically restarted and starts the interval (considering the on time delay) with high level (burst on).

RSUPL Config Gen Func Burst 2.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster DC Offset
Boolean | dc offset (off:F) (TF) This control turns the dc offset on or off. Valid Range: F - off (default) T - on
DBL | dc offset value (0.0) (DBL) This control sets the dc offset value. Valid Range: -10.0 to 10.0 V Default Value: 0.0 Notes: (1) This control has no effect if the dc offset is off.
I32 | dc offset unit (V:0) (I32) This control sets the dc offset unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - dBr 12 - FS 13 - %FS 14 - dBFS 15 - LSBs 16 - d% 17 - bits Notes: (1) This control has no effect if the dc offset is off.
Cluster On Time
DBL | on time (1.0) (DBL) This control sets the time during which the sine has its high level. Valid Range: 20.833 us to 60.0 sec Default Value: 1.0
DBL | level (1.0) (DBL) This control sets the amplitude of the output signal. Valid Range: digital: 0.0 to 1.0 FS (audio data mode) analog: 0.0 to 12.0 V for unbalanced output 0.0 to 24.0 V for balanced output Default Value: 1.0 Notes: (1) Use RSUPL Config Gen Analog Setup.vi or RSUPL Config Gen Analog Setup.vi to set the level limit value.
I32 | on time unit (s:0) (I32) This control sets the on time unit. Valid Range: 0 - s (default) 1 - ms 2 - us 3 - cyc 4 - kcyc 5 - Mcyc Notes: (1) Selection of one of the cycle units (cyc, kcyc, Mcyc), which are relative to frequency, results in a number of cycles - and not the burst time - remaining constant when the frequency is changed.
I32 | level unit (V:0) (I32) This control sets the level unit. Valid Range: analog: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - Vpp 12 - mVpp 13 - uVpp 14 - dBr digital audio data mode 14 - dBr 15 - FS 16 - %FS 17 - dBFS 18 - LSBs 19 - d% 20 - bits
Cluster Frequency
DBL | frequency (50.0) (DBL) This control sets the sinewave frequency. Valid Range: 10.0 Hz to 110.0 kHz Default Value: 50.0
I32 | freq unit (Hz:0) (I32) This control sets the sinewave frequency unit. Valid Range: 0 - Hz (default) 1 - kHz 2 - dHz 3 - dkHz 4 - f/fr 5 - d%Hz 6 - Toct 7 - Oct 8 - Dec
Cluster Interval
DBL | interval (2.0) (DBL) This control sets the burst interval length (burst period). Valid Range: burst on time to 60.0 s Default Value: 2.0
I32 | interval unit (s:0) (I32) This control sets the interval unit. Valid Range: 0 - s (default) 1 - ms 2 - us 3 - min
Cluster On Delay
DBL | burst on delay (0.0) (DBL) This control sets the burst on delay, i.e. the burst state on is delayed by this value when the generation is either started or restarted. Valid Range: 0.0 to 60.0 sec Default Value: 0.0 Notes: (1) If the generator settings are modified or a measurement is (re-)started, the generator is automatically restarted and starts the interval (considering the on time delay) with high level (burst on).
I32 | delay unit (s:0) (I32) This control sets the burst on delay unit. Valid Range: 0 - s (default) 1 - ms 2 - us 3 - min


RSUPL Config Gen Func Modul Distortion

This VI configures the modulation distortion generator. Two superposing sinewave signals are generated. Low-frequency interfering signal and high-frequency useful signal where the interfering signal is one to ten times stronger than the useful signal. It is useful for intermodulation measurements to SMPTE and modulation distortion analysis.
The following settings are available:
- analog/digital generator switch
- dc offset
- total level
- upper frequency
- lower frequency
- frequency offset
- dither
- level ratio (LF/UF)

Notes:
(1) This function is available only when generator is either in digital audio data or analog mode.

RSUPL Config Gen Func Modul Distortion.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster DC Offset
Boolean | dc offset (off:F) (TF) This control turns the dc offset on or off. Valid Range: F - off (default) T - on
DBL | dc offset value (0.0) (DBL) This control sets the dc offset value. Valid Range: -10.0 to 10.0 V Default Value: 0.0 Notes: (1) This control has no effect if the dc offset is off.
I32 | dc offset unit (V:0) (I32) This control sets the dc offset unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - dBr 12 - FS 13 - %FS 14 - dBFS 15 - LSBs 16 - d% 17 - bits Notes: (1) This control has no effect if the dc offset is off.
Cluster Dither
Boolean | dither (off:F) (TF) This control turns the dither on or off. Valid Range: F - off (default) T - on Notes: (1) When on, a noise component is superimposed on the output signal. (2) This control is active only in audio data digital mode.
DBL | dither value (0.0) (DBL) This control sets the amplitude of the noise superimposed on output signals (dither). Valid Range: 0.0 to 1.0 FS Default Value: 0.0 Notes: (1) This control has an effect only when dither is on.
I32 | dither unit (FS:1) (I32) This control sets the dither noise amplitude unit. Valid Range: 0 - dBr 1 - FS (default) 2 - %FS 3 - dBFS 4 - LSBs 5 - d% 6 - bits Notes: (1) This control has an effect only when dither is on.
I32 | pdf (gauss:0) (I32) This control specifies the amplitude distribution (probability distribution function) of the superimposed noise signal (dither). Valid Range: 0 - gauss (default) 1 - triangle 2 - rectangle Notes: (1) This control has an effect only when dither is on.
Cluster Frequency
Boolean | freq offset (off:F) (TF) This control turns the frequency offset on or off. Valid Range: F - off (default) T - on Notes: (1) This control is active only in analog generator mode. (2) If on, frequency offset of +0.1% is applied.
DBL | upper freq (5000.0) (DBL) This control sets the upper frequency. Valid Range: 4.0 kHz to 110.0 kHz Default Value: 5000.0
I32 | freq unit (Hz:0) (I32) This control sets the upper and lower frequency units. Valid Range: 0 - Hz (default) 1 - kHz 2 - dHz 3 - dkHz 4 - f/fr 5 - d%Hz 6 - Toct 7 - Oct 8 - Dec
DBL | lower frequency (50.0) (DBL) This control sets the lower frequency. Valid Range: 30.0 Hz to 500.0 Hz Default Value: 50.0
Cluster Level
DBL | total level (1.0) (DBL) This control sets the total amplitude of both sinewave signals. Valid Range: digital: 0.0 to 1.0 FS (audio data mode) analog: 0.0 to 10.964 Vrms for unbalanced output 0.0 to 21.927 Vrms for balanced output Default Value: 1.0 Notes: (1) Use RSUPL Config Gen Analog Setup.vi or RSUPL Config Gen Digital Setup.vi to set the level limit value.
I32 | level unit (V:0) (I32) This control sets the level unit. Valid Range: analog: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - Vpp 12 - mVpp 13 - uVpp 14 - dBr digital audio data mode 14 - dBr 15 - FS 16 - %FS 17 - dBFS 18 - LSBs 19 - d% 20 - bits
DBL | level ratio LF/UF (4.0) (DBL) This control sets the lower/upper frequency signal level ratio. Valid Range: 1.0 to 10.0 Default Value: 4.0


RSUPL Config Gen Func Diff Freq Distortion

This VI configures the difference frequency distortion function of the generator. Two closely spaced sinewave signals of the same amplitude for intermodulation measurements (according to DIN-IEC 268-3) are generated by the instrument.
The following settings are available:
- dc offset
- total level
- upper/mean frequency
- difference frequency
- dither
- frequency offset

Notes:
(1) This function is available only when generator is either in digital audio data or analog mode.

RSUPL Config Gen Func Diff Freq Distortion.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Boolean gen mode (IEC 118:F) (TF)
This control defines the generating standard.

Valid Range:
F - IEC 118 (default)
T - IEC 268
Cluster DC Offset
Boolean | dc offset (off:F) (TF) This control turns the dc offset on or off. Valid Range: F - off (default) T - on
DBL | dc offset value (0.0) (DBL) This control sets the dc offset value. Valid Range: -10.0 to 10.0 V Default Value: 0.0 Notes: (1) This control has no effect if the dc offset is off.
I32 | dc offset unit (V:0) (I32) This control sets the dc offset unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - dBr 12 - FS 13 - %FS 14 - dBFS 15 - LSBs 16 - d% 17 - bits Notes: (1) This control has no effect if the dc offset is off.
Cluster Level
DBL | total level (1.0) (DBL) This control sets the amplitude of the output sinewave. Valid Range: digital: 0.0 to 1.0 FS (audio data mode) 0.0 to 5.0 UI (jitter mode) 0.0 to 7.071 Vrms (common mode) analog: 0.0 to 10.0 Vrms for unbalanced output 0.0 to 20.0 Vrms for balanced output Default Value: 1.0 Notes: (1) Use RSUPL Config Gen Analog Setup.vi or RSUPL Config Gen Digital Setup.vi to set the level limit value.
I32 | level unit (V:0) (I32) This control sets the amplitude unit of the output sinewave. Valid Range: analog and digital common mode 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - Vpp 12 - mVpp 13 - uVpp 14 - dBr digital audio data mode 14 - dBr 15 - FS 16 - %FS 17 - dBFS 18 - LSBs 19 - d% 20 - bits digital jitter mode 14 - dBr 21 - UI 22 - %UI 23 - dBUI 24 - ppm 25 - ns 26 - UIr
Cluster Dither
Boolean | dither (off:F) (TF) This control turns the dither on or off. Valid Range: F - off (default) T - on Notes: (1) When on, a noise component is superimposed on the output signal. (2) This control is active only in audio data digital mode.
DBL | dither value (0.0) (DBL) This control sets the amplitude of the noise superimposed on output signals (dither). Valid Range: 0.0 to 1.0 FS Default Value: 0.0 Notes: (1) This control has an effect only when dither is on.
I32 | dither unit (FS:1) (I32) This control sets the dither noise amplitude unit. Valid Range: 0 - dBr 1 - FS (default) 2 - %FS 3 - dBFS 4 - LSBs 5 - d% 6 - bits Notes: (1) This control has an effect only when dither is on.
I32 | pdf (gauss:0) (I32) This control specifies the amplitude distribution (probability distribution function) of the superimposed noise signal (dither). Valid Range: 0 - gauss (default) 1 - triangle 2 - rectangle Notes: (1) This control has an effect only when dither is on.
Cluster Equalizer
Boolean | equalizer (off:F) (TF) This control turns the equalizer on or off. Valid Range: F - off (default) T - on Notes: (1) When on, the equalizer table including frequency specifications and the appertaining voltage amplification factors is activated.
String | equalizer file name ("*.veq") (abc) This control specifies the equalizer filename. Valid Range: any valid dos filename with "veq" extension Default Value: *.veq Notes: (1) The specified file must exist on the instrument, otherwise an error is generated.
Cluster Frequency
Boolean | freq offset (off:F) (TF) This control turns the frequency offset on or off. Valid Range: F - off (default) T - on Notes: (1) This control is active only in analog generator mode. (2) If on, a frequency offset of +0.1% is applied.
DBL | upp/mean frequency (1000.0) (DBL) This control sets the upper frequency in the IEC118 generator mode and mean frequency in IEC268 in IEC268 generator mode. Valid Range: 200.0 Hz to 110.0 kHz Default Value: 1000.0
DBL | diff frequency (100.0) (DBL) This control sets the frequency difference between both sines. Valid Range: 80.0 Hz to 1.0 kHz Default Value: 100.0
U32 | freq unit (Hz:0) (I32) This control sets the upper/mean and difference frequency units. Valid Values: 0 - Hz (default) 1 - kHz 2 - dHz 3 - dkHz 4 - f/fr 5 - d%Hz 6 - Toct 7 - Oct 8 - Dec


RSUPL Config Gen Func Random

This VI configures a random signal generation.
The following settings are available:
- analog/digital generator switch
- dc offset
- level
- shape
- domain
- spacing
- upper frquency
- mean frequency
- lower frequency
- equalizer
- probability distribution function

Notes:
(1) This VI does not return until the instrument completes its configuration. This may take up to 2 minutes.

RSUPL Config Gen Func Random.vi

Boolean Domain (time:F) (TF)
This control selects the domain for definition of the noise signal.

Valid Range:
F - time (default)
T - frequency

Notes:
(1) If set to freq, sine lines with settable amplitudes are generated and superimposed on each other using defined frequency spacing to produce the output signal.
(2) If set to time, noise signal generation is effected by nested random functions which have been optimized to produce evenly distributed noise.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster DC Offset
Boolean | dc offset (off:F) (TF) This control turns the dc offset on or off. Valid Range: F - off (default) T - on
DBL | dc offset value (0.0) (DBL) This control sets the dc offset value. Valid Range: -10.0 to 10.0 V Default Value: 0.0 Notes: (1) This control has no effect if the dc offset is off.
I32 | dc offset unit (V:0) (I32) This control sets the dc offset unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - dBr 12 - FS 13 - %FS 14 - dBFS 15 - LSBs 16 - d% 17 - bits Notes: (1) This control has no effect if the dc offset is off.
Cluster Level
DBL | level value (1.0) (DBL) This control sets the amplitude of the output sinewave. Valid Range: digital: 0.0 to 1.0 FS (audio data mode) 0.0 to 5.0 UI (jitter mode) 0.0 to 7.071 Vrms (common mode) analog: 0.0 to 10.0 Vrms for unbalanced output 0.0 to 20.0 Vrms for balanced output Default Value: 1.0 Notes: (1) Use RSUPL Config Gen Analog Setup.vi or RSUPL Config Gen Digital Setup.vi to set the level limit value.
Boolean | level (total:F) (TF) This control selects between RMS andpeak output level specification. Valid Range: F - total (default) T - RMS Notes: (1) If set to total, the control 'level value' accepts peak output level, otherwise it accepts rms value.
I32 | level unit (V:0) (I32)) This control sets the amplitude unit of the output sinewave. Valid Range: analog and digital common mode 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - dBr digital audio data mode 12 - FS 13 - %FS 14 - dBFS 15 - LSBs 16 - d% 17 - bits digital jitter mode 11 - dBr 18 - UI 19 - %UI 20 - dBUI 21 - ppm 22 - ns 23 - UIr
Cluster Equalizer
Boolean | equalizer (off:F) (TF) This control turns the equalizer on or off. Valid Range: F - off (default) T - on Notes: (1) When on, the equalizer table including frequency specifications and the appertaining voltage amplification factors is activated.
String | equalizer file name ("*.veq") (abc) This control specifies the equalizer filename. Valid Range: any valid dos filename with "veq" extension Default Value: *.veq Notes: (1) The specified file must exist on the instrument, otherwise an error is generated.
Cluster Spacing / Frequency
Boolean | spacing (user defined:F) (TF) This control sets the frequency spacing mode. Valid Range: F - user defined (default) T - analyzer track Notes: (1) If set to analyzer track, the value for the FFT analysis frequency spacing is automatically adopted. This setting is ideal for an analysis with the rectangular window. If FFT is not selected on the analyzer, this setting is not valid. (2) If set to user defined, use control 'spacing in Hz' to enter user spacing value.
DBL | spacing value in Hz (10.0) (DBL) This control sets the frequency spacing value in Hz. Valid Range: analog: 2.9 to 10875.0 Hz digital: internal sample freq/16384 to 10875.0 Hz Default Value: 10.0 Hz Notes: (1) The entered value is corrected to the next settable value.
DBL | upper/mean freq in Hz (10000.0) (DBL) This control sets the upper frequency if the 'domain' is set to frequency with 'shape' set to white and pink; sets the mean frequency if the 'domain' is set to frequency with 'shape' set to 1/3-octave. Valid Range: upper frequency: lower freq + 1 x spacing to 117/256 x sampling rate mean frequency: 11.225 to 19.377 kHz Default Value: 1000.0 Hz
DBL | lower freq in Hz (500.0) (DBL) This control specifies lower frequency limit of the generated noise. Valid Range: spacing freq to 117/256 x sampling rate - 1x spacing Default Value: 500.0 Hz Notes: (1) This control is valid only if the 'domain' is set to frequency with 'shape' set to white and pink.
Cluster Shape / Distribution
I32 | pdf (gauss:0) (I32) This control specifies the amplitude distribution (probability distribution function) of the time domain noise signal. Valid Range: 0 - gauss (default) 1 - triangle 2 - rectangle
I32 | shape (white:0) (I32) This control selects which function is used to determine the amplitudes of the single sine lines. Valid Range: 0 - white (default) 1 - pink 2 - 1/3-octave 3 - file Notes: (1) If set to white, all sine lines between start and stop values have the same amplitudes. (2) If set to pink, the amplitude of the sine lines between start and stop value is proportional to sqrt(1/f). (3) If set to 1/3-octave, it is similar to pink, however band-limited to 1/3 octave with settable mean frequency. (4) If set to file, use control 'shape file' to pass a name of the shape file.
String | shape file ("*.veq") (abc) This control specifies the shape file name. Valid Range: all existing dos files with extension *.veq containing correct shape data Default Value: *.veq Notes: (1) This control has no effect if the control 'shape' is not set to file.


RSUPL Config Gen Func Arbitrary

This VI configures the arbitrary waveform generator. The waveform can consist of up to 16384 points (samples). The following settings are available:
- dc offset
- level
- arbitrary waveform file

RSUPL Config Gen Func Arbitrary.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
String filename "*.ttf" (abc)
This control specifies the arbitrary waveform file.

Valid Range: any existing dos filename containing correct wave data.

Default Value "*.ttf"

Notes:
(1) UPL supports two different waveform file formats: AWD (Arbitrary Waveform Designer software package output file) and ASCII format table file. See the User's Manual for more information.
Cluster DC Offset
Boolean | dc offset (off:F) (TF) This control turns the dc offset on or off. Valid Range: F - off (default) T - on
DBL | dc offset value (0.0) (DBL) This control sets the dc offset value. Valid Range: -10.0 to 10.0 V Default Value: 0.0 Notes: (1) This control has no effect if the dc offset is off.
I32 | dc offset unit (V:0) (I32) This control sets the dc offset unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - dBr 12 - FS 13 - %FS 14 - dBFS 15 - LSBs 16 - d% 17 - bits Notes: (1) This control has no effect if the dc offset is off.
Cluster Level
DBL | level value (1.0) (DBL) This control sets the amplitude of the output sinewave. Valid Range: digital: 0.0 to 1.0 FS (audio data mode) 0.0 to 5.0 UI (jitter mode) 0.0 to 7.071 Vrms (common mode) analog: 0.0 to 10.0 Vrms for unbalanced output 0.0 to 20.0 Vrms for balanced output Default Value: 1.0 Notes: (1) Use RSUPL Config Gen Analog Setup.vi or RSUPL Config Gen Digital Setup.vi to set the level limit value.
Boolean | level (total:F) (TF) This control selects between RMS andpeak output level specification. Valid Range: F - total (default) T - RMS Notes: (1) If set to total, the control 'level value' accepts peak output level, otherwise it accepts rms value.
I32 | level unit (V:0) (I32)) This control sets the amplitude unit of the output sinewave. Valid Range: analog and digital common mode 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - dBr digital audio data mode 12 - FS 13 - %FS 14 - dBFS 15 - LSBs 16 - d% 17 - bits digital jitter mode 11 - dBr 18 - UI 19 - %UI 20 - dBUI 21 - ppm 22 - ns 23 - UIr


RSUPL Config Gen Func Polarity

This VI configures the the polarity test signal generation. It is a specific case of sine 2 burst signal with the following characteristics: Frequency = sample rate/80 (digital) or 1.2 kHz (analog); On-time = 1 cycle; Interval = 2 cycles.
The following settings are available:
- analog/digital generator switch
- dc offset
- level

Notes:
(1) This function is available only when generator is either in digital audio data or analog mode.

RSUPL Config Gen Func Polarity.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster DC Offset
Boolean | dc offset (off:F) (TF) This control turns the dc offset on or off. Valid Range: F - off (default) T - on
DBL | dc offset value (0.0) (DBL) This control sets the dc offset value. Valid Range: -10.0 to 10.0 V Default Value: 0.0 Notes: (1) This control has no effect if the dc offset is off.
I32 | dc offset unit (V:0) (I32) This control sets the dc offset unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - dBr 12 - FS 13 - %FS 14 - dBFS 15 - LSBs 16 - d% 17 - bits Notes: (1) This control has no effect if the dc offset is off.
Cluster Level
DBL | level (1.0) (DBL) This control sets the amplitude of the output sinewave. Valid Range: digital: 0.0 to 1.0 FS (audio data mode) 0.0 to 5.0 UI (jitter mode) 0.0 to 7.071 Vrms (common mode) analog: 0.0 to 10.0 Vrms for unbalanced output 0.0 to 20.0 Vrms for balanced output Default Value: 1.0 Notes: (1) Use RSUPL Config Gen Analog Setup.vi or RSUPL Config Gen Digital Setup.vi to set the level limit value.
I32 | level unit (V:0) (I32) This control sets the amplitude unit of the output sinewave. Valid Range: analog and digital common mode 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - Vpp 12 - mVpp 13 - uVpp 14 - dBr digital audio data mode 14 - dBr 15 - FS 16 - %FS 17 - dBFS 18 - LSBs 19 - d% 20 - bits digital jitter mode 14 - dBr 21 - UI 22 - %UI 23 - dBUI 24 - ppm 25 - ns 26 - UIr


RSUPL Config Gen Sweep Setup

This VI configures the sweep system of the generator. It is possible to configure either a single dimensional sweep or two dimensional sweep. Sweepable functions are: sine, sine burst, sine 2 burst, modulation distortion and difference frequency distortion.
The following settings are available:
- sweep control
- x axis
- x axis filename
- z axis
- z axis filename
- next step
- dwell time
- dwell filename

RSUPL Config Gen Sweep Setup.vi

I32 Sweep Control (off:0) (I32)
This control activates/deactivates the sweep system and specifies the data source and run.

Valid Range:
0 - off (default)
1 - auto sweep
2 - auto list
3 - manual sweep
4 - manual list

Notes:
(1) If set to either auto sweep or manual sweep, tables with equidistant rising or falling values are generated according to the sweep parameters (start value, stop value and step) provided by the individual sweep functions.
(2) If set to either auto list or manual list, the sweep values are obtained from files.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Step Control
I32 | next step (analyzer sync:0) (I32) This control selects the automatic sweep stepping. Valid Range: 0 - analyzer synchronization (default) 1 - dwell value 2 - dwell file Notes: (1) If set to analyzer sync, the sweep continues after a valid measurement has been obtained. This is recommended in generator/analyzer mode. (2) If set to dwell value, the sweep continues after a specified time (dwell time in sec) has elapsed. This is required for sweeps with external analyzer. (3) If set to dwell file, the time synchronization is based on the times obtained from the file (dwell file name). the sweep continues after specified times which are read out of a file and interpolated on the basis of the existing x axis. this is required for sweeps with external analyzer, if the measuring or settling time of the analyzer and/or DUT depends on the respective sweep point.
DBL | dwell time in sec (0.1) (DBL) This control specifies the sweep dwell time. Valid Range: 0.0 to 1000.0 sec. Default Value: 0.1 sec Notes: (1) This control si active only if the control 'next step' is set to dwell value.
String | dwell file name "*.dwl" (abc) This control specifies a file containing the dwell times. Valid Range: any existing *.dwl file with correct dwell data Notes: (1) This control si active only if the control 'next step' is set to dwell file.
Cluster X Axis
I32 | x axis (frequency:0) (I32) This control specifies x axis sweep parameter. Valid Range: 0 - frequency (default) 1 - voltage 2 - on time 3 - interval Notes: (1) If set to frequency, signal frequency (sine, sine burst, sine 2 burst), useful frequency (modulation distortion) or center frequency (difference frequency distortion) is swept. (2) If set to voltage, signal voltage (sine, sine burst, sine 2 burst) or total voltage (modulation distortion, difference frequency distortion) is swept. (3) If set to on time, the time of high level with burst signals is swept. (4) If set to interval, the interval time with burst sinals is swept. (5) Theoretically, the same parameter may be set for x and z axes. This does, however, not make sense in normal practical use.
String | x axis file name "*.spf" (abc) This control specifies the x axis sweep filename. It requires to be passed a file containing correct sweep values for selected sweep parameter. Valid Range: any existing *.spf file with correct sweep data Default Value: *.spf Notes: (1) This control is active only if 'sweep control' is set to auto list or manual list. (2) It is assumed that the file contains sweep data corresponding to selected sweep parameter, e.g. frequency sweep points if 'x axis' is set to frequency etc. (3) To specify sweep parameters for auto sweep and manual sweep modes use VIs configuring individual sweep parameters.
Cluster Z Axis
I32 | z axis (off:4) (I32) This control specifies z axis sweep parameter. Setting this control to other than off will configure a two-dimensional sweep Valid Range: 0 - frequency (default) 1 - voltage 2 - on time 3 - interval 4 - off Notes: (1) If set to frequency, signal frequency (sine, sine burst, sine 2 burst), useful frequency (modulation distortion) or center frequency (difference frequency distortion) is swept. (2) If set to voltage, signal voltage (sine, sine burst, sine 2 burst) or total voltage (modulation distortion, difference frequency distortion) is swept. (3) If set to on time, the time of high level with burst signals is swept. (4) If set to interval, the interval time with burst sinals is swept. (5) If set to off, the sweep is one-dimensional. (6) Theoretically, the same parameter may be set for x and z axes. This does, however, not make sense in normal practical use.
String | z axis file name "*.spf" (abc) This control specifies the z axis sweep filename. It requires to be passed a file containing correct sweep values for selected sweep parameter. Valid Range: any existing *.spf file with correct sweep data Default Value: *.spf Notes: (1) This control is active only if 'sweep control' is set to auto list or manual list. (2) It is assumed that the file contains sweep data corresponding to selected sweep parameter, e.g. frequency sweep points if 'x axis' is set to frequency etc. (3) To specify sweep parameters for auto sweep and manual sweep modes use VIs configuring individual sweep parameters.


RSUPL Config Gen Sweep Freq

This VI configures frequency sweep parameters. Use this VI to set parameters for auto sweep and manual sweep modes (RSUPL Config Gen Sweep Setup.vi, control 'sweep control'). The following settings are available:
- axis
- start frequency
- stop frequency
- points/step width
- spacing

Notes:
(1) This function is aplicable to the following generator functions:
sine, sine burst, sine 2 burst, modulation distortion, difference frequency distortion.

RSUPL Config Gen Sweep Freq.vi

Boolean axis (X axis:F) (TF)
Selects the axis to set the sweep parameters for.

Valid Range:
F - x axis (default)
T - z axis, two dimensional sweep
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Frequency
DBL | start frequency (20000.0) (DBL) This control sets the start frequency of a sweep function. Valid Range: 10.0 Hz to 110.0 kHz Default Value: 20000.0
DBL | stop frequency (20.0) (DBL) This control sets the stop frequency of a sweep function. Valid Range: 10.0 Hz to 110.0 kHz Default Value: 20.0
I32 | freq unit (Hz:0) (I32) This control sets the frequency unit of a sweep function. Valid Range: 0 - Hz (default) 1 - kHz 2 - dHz 3 - dkHz 4 - f/fr 5 - d%Hz 6 - Toct 7 - Oct 8 - Dec
Cluster Spacing
DBL | points/step width (30.0) (DBL) This control specifies a number of points or sweep step width, depending on the 'spacing' mode. Valid Range: points: 2 to 1024, no units lin step: 10.0 Hz to 110.0 kHz log step: 0.001 to 1000.0, no units Default Value: 30.0
I32 | spacing (lin points:0) (I32) This control sets the sweep range spacing. Valid Range: 0 - lin points (default) 1 - log points 2 - lin step 3 - log step
I32 | step unit (Hz:0) (I32) This control sets the frequency unit of a sweep step Valid Range: 0 - Hz (default) 1 - kHz 2 - dHz 3 - dkHz 4 - f/fr 5 - d%Hz 6 - Toct 7 - Oct 8 - Dec


RSUPL Config Gen Sweep Level

This VI configures level (voltage) sweep parameters. Use this VI to set parameters for auto sweep and manual sweep modes (RSUPL Config Gen Sweep Setup.vi, control 'sweep control'). The following settings are available:
- axis
- start level
- stop level
- points/step width
- spacing

Notes:
(1) This function is aplicable to the following generator functions:
sine, sine burst, sine 2 burst, modulation distortion, difference frequency distortion.

RSUPL Config Gen Sweep Level.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Boolean axis (X axis:F) (TF)
Selects the axis to set the sweep parameters for.

Valid Range:
F - x axis (default)
T - z axis, two dimensional sweep
Cluster Level
DBL | start level (0.01) (DBL) This control sets the start level of the sweep function. Valid Range: digital: 0.0 to 1.0 FS (audio data mode) 0.0 to 5.0 UI (jitter mode) 0.0 to 7.071 Vrms (common mode) analog: 0.0 to 10.0 Vrms for unbalanced output 0.0 to 20.0 Vrms for balanced output Default Value: 0.01 Notes: (1) Use RSUPL Config Gen Analog Setup.vi or RSUPL Config Gen Digital Setup.vi to set the level limit value.
DBL | stop level (0.5) (DBL) This control sets the stop level of the sweep function. Valid Range: digital: 0.0 to 1.0 FS (audio data mode) 0.0 to 5.0 UI (jitter mode) 0.0 to 7.071 Vrms (common mode) analog: 0.0 to 10.0 Vrms for unbalanced output 0.0 to 20.0 Vrms for balanced output Default Value: 0.5 Notes: (1) Use RSUPL Config Gen Analog Setup.vi or RSUPL Config Gen Digital Setup.vi to set the level limit value.
I32 | level unit (V:0) (I32) This control sets the level unit of the sweep function. Valid Range: analog and digital common mode 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - Vpp 12 - mVpp 13 - uVpp 14 - dBr digital audio data mode 14 - dBr 15 - FS 16 - %FS 17 - dBFS 18 - LSBs 19 - d% 20 - bits digital jitter mode 14 - dBr 21 - UI 22 - %UI 23 - dBUI 24 - ppm 25 - ns 26 - UIr
Cluster Spacing
I32 | spacing (lin points:0) (I32) This control sets the sweep range spacing. Valid Range: 0 - lin points (default) 1 - log points 2 - lin step 3 - log step
DBL | points/step width (30.0) (DBL) This control specifies a number of points or sweep step width, depending on the 'spacing' mode. Valid Range: points: 2 to 1024, no units lin step: digital: 0.0 to 1.0 FS (audio data mode) 0.0 to 5.0 UI (jitter mode) 0.0 to 7.071 Vrms (common mode) analog: 0.0 to 10.0 Vrms for unbalanced output 0.0 to 20.0 Vrms for balanced output log step: 0.001 to 1000.0, no units Default Value: 30.0
I32 | step unit (V:0) (I32) This control sets the step unit of the sweep function. Valid Range: analog and digital common mode 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - dmV 10 - duV 11 - Vpp 12 - mVpp 13 - uVpp 14 - dBr digital audio data mode 14 - dBr 15 - FS 16 - %FS 17 - dBFS 18 - LSBs 19 - d% 20 - bits digital jitter mode 14 - dBr 21 - UI 22 - %UI 23 - dBUI 24 - ppm 25 - ns 26 - UIr


RSUPL Config Gen Sweep On Time

This VI configures on time sweep parameters. Use this VI to set parameters for auto sweep and manual sweep modes (RSUPL Config Gen Sweep Setup.vi, control 'sweep control'). The following settings are available:
- axis
- start on time
- stop on time
- points/step width
- spacing

Notes:
(1) This function is aplicable to the following generator functions:
sine burst, sine 2 burst.

RSUPL Config Gen Sweep On Time.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Boolean axis (X axis:F) (TF)
Selects the axis to set the sweep parameters for.

Valid Range:
F - x axis (default)
T - z axis, two dimensional sweep
Cluster On Time
DBL | start on time (0.01) (DBL) This control sets the start on time value. Valid Range: 20.833 us to 60.0 sec Default Value: 0.01
DBL | stop on time (0.2) (DBL) This control sets the stop on time value. Valid Range: 20.833 us to 60.0 sec Default Value: 0.2
I32 | on time unit (s:0) (I32) This control sets the on time unit. Valid Range: 0 - s (default) 1 - ms 2 - us 3 - cyc 4 - kcyc 5 - Mcyc Notes: (1) Selection of one of the cycle units (cyc, kcyc, Mcyc), which are relative to frequency, results in a number of cycles - and not the burst time - remaining constant when the frequency is changed.
Cluster Spacing
DBL | points/step width (30.0) (DBL) This control specifies a number of points or sweep step width, depending on the 'spacing' mode. Valid Range: points: 2 to 1024, no units lin step: 20.833 us to 60 sec log step: 0.001 to 1000.0, no units Default Value: 30.0
I32 | step unit (s:0) (I32) This control sets the on time unit. Valid Range: 0 - s (default) 1 - ms 2 - us 3 - cyc 4 - kcyc 5 - Mcyc Notes: (1) Selection of one of the cycle units (cyc, kcyc, Mcyc), which are relative to frequency, results in a number of cycles - and not the burst time - remaining constant when the frequency is changed.
I32 | spacing (lin points:0) (I32) This control sets the sweep range spacing. Valid Range: 0 - lin points (default) 1 - log points 2 - lin step 3 - log step


RSUPL Config Gen Sweep Interval

This VI configures interval sweep parameters. Use this VI to set parameters for auto sweep and manual sweep modes (RSUPL Config Gen Sweep Setup.vi, control 'sweep control'). The following settings are available:
- axis
- start interval
- stop interval
- points/step width
- spacing

Notes:
(1) This function is aplicable to the following generator functions:
sine burst, sine 2 burst.

RSUPL Config Gen Sweep Interval.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Boolean axis (X axis:F) (TF)
Selects the axis to set the sweep parameters for.

Valid Range:
F - x axis (default)
T - z axis, two dimensional sweep
Cluster Interval
DBL | start interval (1.0) (DBL) This control sets the start burst interval length (burst period). Valid Range: burst on time to 60.0 s Default Value: 1.0
DBL | stop interval (0.02) (DBL) This control sets the stop burst interval length (burst period). Valid Range: burst on time to 60.0 s Default Value: 0.02
I32 | interval unit (s:0) (I32) This control sets the interval unit. Valid Range: 0 - s (default) 1 - ms 2 - us 3 - min
Cluster Spacing
DBL | points/step width (30.0) (DBL) This control specifies a number of points or sweep step width, depending on the 'spacing' mode. Valid Range: points: 2 to 1024, no units lin step: 20.833 us to 60.0 sec log step: 0.001 to 1000.0, no units Default Value: 30.0
I32 | step unit (s:0) (I32) This control sets the interval step width unit. Valid Range: 0 - s (default) 1 - ms 2 - us 3 - min
I32 | spacing (lin points:0) (I32) This control sets the sweep range spacing. Valid Range: 0 - lin points (default) 1 - log points 2 - lin step 3 - log step


RSUPL Config Analyzer Analog Setup

This VI configures the analog analyzer. The following settings are available:
- instrument
- channels
- channel 1 input
- channel 1 impedance
- channel 1 common
- channel 1 range mode
- channel 1 range
- channel 2 input
- channel 2 impedance
- channel 2 common
- channel 2 range mode
- channel 2 range
- reference impedance

RSUPL Config Analyzer Analog Setup.vi

DBL ref impedance in ohm (600.0) (DBL)
Sets the impedance as reference for computing the units dBm, W, d%W, dW, P/Pr, and %P/Pr.

Valid Range: 1.0 mOhm to 100.0 kOhm

Dafault Value: 600.0 Ohms
I32 channels (1:0) (I32)
Selects the input channel(s).

Valid Range:
0 - 1 (default)
1 - 2
2 - 1 & 2
3 - 2 = 1
4 - 1 = 2
Boolean instrument (analog 22kHz:F) (TF)
Selects the analog analyzer.

Valid Range:
F - analog 22kHz (default)
T - analog 110kHz
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Ch1 Input Selection Ch1 Input Selection Cluster

Contains the following controls:
- Ch1 Input
- Ch1 Impedance
- Ch1 Common
- Ch1 Range Mode
- Ch1 Range Selector.
Boolean | Ch1 input (balanced:F) (TF) Selects the input mode of channel 1. Valid Range: F - balanced (default) T - generator channel 2 Notes: (1) This control is not active if 'channels' is set to 2 (control value 1).
I32 | Ch1 imp (600 Ohms:1) (I32) Selects the input impedance. Valid Range: 0 - 300 Ohm 1 - 600 Ohm (default) 2 - 200 kOhm Notes: (1) This control is active only if channel 1 input is set to balanced.
Boolean | Ch1 common (float:F) (TF) Selects the common reference of potential of the XLR input. Valid Range: F - float (default) T - ground Notes: (1) This control is active only if channel 1 input is set to balanced.
I32 | Ch1 range mode (auto:0) (I32) Selects the channel 1 measurement range. For selection 'fix' the range is set by means of the channel 1 range control. Lower - the set range is kept as the lowest range. Valid Range: 0 - auto (default) 1 - fix 2 - lower
I32 | Ch1 range (18.0 mV:0) (I32) Specifies the channel 1 range. Valid Range: 0 - 18 mV (default) 1 - 30 mV 2 - 60 mV 3 - 100 mV 4 - 180 mV 5 - 300 mV 6 - 600 mV 7 - 1.0 V 8 - 1.8 V 9 - 3.0 V 10 - 6.0 V 11 - 10.0 V 12 - 18.0 V 13 - 30.0 V Notes: (1) This control is active only if 'channel 1 range mode' is set to fix.
Cluster Ch2 Input Selection Ch2 Input Selection Cluster

Contains the following controls:
- Ch2 Input
- Ch2 Impedance
- Ch2 Common
- Ch2 Range Mode
- Ch2 Range Selector.
Boolean | Ch2 input (balanced:F) (TF) Selects the input mode of channel 1. Valid Range: F - balanced (default) T - generator channel 2 Notes: (1) This control is not active if 'channels' is set to 2 (control value 1).
I32 | Ch2 imp (600 Ohms:1) (I32) Selects the input impedance. Valid Range: 0 - 300 Ohm 1 - 600 Ohm (default) 2 - 200 kOhm Notes: (1) This control is active only if channel 1 input is set to balanced.
Boolean | Ch2 common (float:F) (TF) Selects the common reference of potential of the XLR input. Valid Range: F - float (default) T - ground Notes: (1) This control is active only if channel 1 input is set to balanced.
I32 | Ch2 range mode (auto:0) (I32) Selects the channel 1 measurement range. For selection 'fix' the range is set by means of the channel 1 range control. Lower - the set range is kept as the lowest range. Valid Range: 0 - auto (default) 1 - fix 2 - lower
I32 | Ch2 range (18.0 mV:0) (I32) Specifies the channel 1 range. Valid Range: 0 - 18 mV (default) 1 - 30 mV 2 - 60 mV 3 - 100 mV 4 - 180 mV 5 - 300 mV 6 - 600 mV 7 - 1.0 V 8 - 1.8 V 9 - 3.0 V 10 - 6.0 V 11 - 10.0 V 12 - 18.0 V 13 - 30.0 V Notes: (1) This control is active only if 'channel 1 range mode' is set to fix.


RSUPL Config Analyzer Digital Setup

This VI configures the digital analyzer. The following settings are available:
- measurement mode
- input
- audio bits
- channels
- jitter reference
- synchronization
- sampling frequency

RSUPL Config Analyzer Digital Setup.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Input Mode
I32 | channels (1:0) (I32) Selects the input channels. Valid Range: 0 - 1 (default) 1 - 2 2 - both
I32 | input (bal:0) (I32) Selects the input interface. Valid Range: 0 - balanced (XLR) (default) 1 - unbalanced (BNC) 2 - optical 3 - internal
I32 | audio bits (20) (I32) Sets the number of audio bits to be evaluated at a digital interface. Valid Range: 8 to 24 Default Value: 20
Cluster Sampling Frequency
Boolean | sync to (audio in:F) (TF) Indicates the input signal which the analyzer is synchronized to. Valid Range: F - audio in (default) T - reference In Notes: (1) This control is active only if 'measurement mode' is set to audio data.
DBL | sampling freq in Hz (48000.0) (DBL) Sets the sampling frequency. Valid Range: 100.0 Hz to 52.5 kHz Default Value: 48.0 kHz Notes: (1) This control is active only if 'measurement mode' is set to audio data and 'sampling frequency' to value.
I32 | sampling frequency (48 kHz:3) (I32) Sets the signal clock rate. Valid Range: 0 - value 1 - 32 kHz 2 - 44.1 kHz 3 - 48 kHz (default) Notes: (1) This control is active only if measurement mode is set to audio data. (2) Selection 'value' - the value is input in control 'sampling frequency value'.
Cluster Measurement Mode
I32 | meas mode (audio data:0) (I32) Selects the measurement mode. Audio Data - measurement of digital audio data. Jitter/Phase - measurement of the jitter and at the digital audio input and the phase offset to the reference signal. Common/Inp - measurement of the common signal and the digital input amplitude. Valid Range: 0 - audio data (default) 1 - jitter/phase 2 - commpon/inp
I32 | jitter ref (gen clock:0) (I32) Indicates the signal to which the jitter measurement is refered. Valid Range: 0 - generator clock (default) 1 - vari (PLL) 2 - 32.0 (PLL) 3 - 44.1 (PLL) 4 - 48.0 (PLL) Notes: (1) Generator Clock - the generator clock serves as reference signal. (2) Vari (PLL) - the sample signal derived from the input signal via the internal synchronization PLL is used as reference signal. Not possible with Measurement Mode Jitter/Phase. (3) 32.0, 44.1, 48.0 (PLL) - the sample signal derived from the input signal via the internal synchronization PLL is used as reference signal. Synchronization is made via the fixed-frequency VCXO. Not possible with Measurement Mode Jitter/Phase.


RSUPL Config Analyzer Post FFT

This VI enables and configures post FFT subsequent to a specified function. The following settings are available:
- window
- FFT size
- beta factor

RSUPL Config Analyzer Post FFT.vi

I32 window (FFT off:0) (I32)
Enables the FFT and selects the window function.

Valid Range:
0 - FFT off (default)
1 - hanning
2 - rectangular
3 - blackmann-harris
4 - rife vinc 1
5 - rife vinc 2
6 - rife vinc 3
7 - hamming
8 - flat-top
9 - kaiser
I32 FFT size (4096:4) (I32)
This control specifies the FFT size. The larger the FFT size (more calculated points) the better the frequency resolution, however the longer the measuring time.

Valid Range:
0 - 256
1 - 512
2 - 1024
3 - 2048
4 - 4096 (default)
5 - 8192
DBL beta factor (12.0) (DBL)
Sets the beta-factor of the kaiser window.

Valid Range: 1.0 to 20.0

Default Value: 12.0

Notes:
(1) This control is active only if 'window' is set to kaiser.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Config Analyzer Settl

This VI enables and configures the settling procedure. The following settings are available:
- settling type
- samples
- timeout
- tolerance
- parameter
- resolution

RSUPL Config Analyzer Settl.vi

I32 samples (3) (I32)
Sets the number of subsequently measured values compared in the settling process. If settling type is average, then this control specifies the number of measured values used for arithmetic averaging.

Valid Range: 1 to 100

Default Value: 3
DBL timeout in sec (5.0) (DBL)
Defines the timeout after which the test loop is aborted if the settling mechanism does not recognize a stabilization of the measured value within the specified time.

Valid Range: 0.001 s to 10.0 s

Default Value: 5.0 s
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Setup
I32 | settling type (off:0) (I32) Enables settling process and specifies the type of settling. Valid Range: 0 - off (default) 1 - exponential 2 - flat 3 - average Notes: (1) Exponential - specifies exponential course of the tolerance and resolution. (2) Flat - specifies horizontal course of the tolerance and resolution. (3) Average - arithmetic averaging of the results. Not valid with level trigger starting condition.
I32 | parameter (function:1) (I32) Selects the function to which the settling will be applied. Valid Range: 0 - trigger 1 - function (default) 3 - frequency 4 - phase
Cluster Tolerance
DBL | tolerance (0.1) (DBL) Specifies the maximally permissible deviation from the preceeding measured value. Valid Range: 0.001 % to 10.0 % or 0.000087 dB to 0.828 dB Default Value: 0.1 Notes: (1) This control is active only if 'settling type' is set to exponential or flat.
Boolean | tolerance unit (%:F) (TF) Sets the tolerance unit. Valid Range: F - % (default) T - dB Notes: (1) This control is active only if 'settling type' is set to exponential or flat.
Cluster Resolution
DBL | resolution (0.001) (DBL) Defines the measured value resolution considered if the measured value does not satisfy the tolerance limits. Valid Range: 1.0 uV to 10.0 V 0.0 FS to 0.1 FS 1.0E-6 % to 10.0 % 100.0 uHz to 10.0 Hz 0.1E-3 Deg to 10.0 Deg Default Value: 0.001 Notes: (1) This control is active only if 'settling type' is set to exponential or flat.
I32 | resolution unit (V:0) (I32) Sets the resolution unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - W 7 - mW 8 - uW 9 - FS 10 - %FS 11 - dBFS 12 - LSBs 13 - d% 14 - bits 15 - dBr 16 - Hz 17 - Deg 18 - Rad


RSUPL Config Analyzer Trig

This VI configures the triggering system of the analyzer.
The following settings are available:
- start condition
- delay in seconds
- time in seconds
- points
- variation in %
- min level
- start value
- stop value

RSUPL Config Analyzer Trig.vi

I32 start condition (auto:0) (I32)
Specifies event which triggers an action.

Valid Range:
0 - auto (default)
1 - time tick
2 - frequency channel 1
3 - frequency channel 2
4 - level channel 1
5 - level channel 2
6 - level trigger channel 1
7 - level trigger channel 2
8 - time chart
9 - frequency fast channel 1
10 - frequency fast channel 2

Notes:
(1) Auto - continuous measurement mode without trigger condition.
(2) Time Tick - measurement is triggered at regular intervals. The intervals for starting measurement are determined by the distance between the timeticks.
(3) Frequency Channel 1, 2, Frequency Sweep Channel 1, 2 - tracing of measured values because a change in frequency was noted at analyzer input channel 1 or 2.
(4) Level Channel 1, 2 - tracing of measured values because a change in voltage was noted at analyzer input channel 1 or 2.
(5) Level Trigger Channel 1, 2 - measured value triggering because of a sudden voltage change at analyzer input channel 1 or 2.
(6) Time Chart - measured values of the running continuous measurement are entered in a time chart in the time pattern that can be entered by means of control Time.
DBL delay in sec (0.0) (DBL)
Determines the waiting time required from the specific events to the restart of a measurement in order to allow the device under test to settle.

Valid Range: 0.0 s to 10.0 s

Default Value: 0.0 s

Notes:
(1) This control is active only if 'start condition' is not set to time tick or time chart.
DBL variation in % (10.0) (DBL)
Inputs the value by which the input frequency or input voltage must be varied at least in order to trigger a measurement.

Valid Range: 0.1 % to 50.0 %

Default Value: 10.0 %

Notes:
(1) This control is active only if 'start condition' is not set to time tick or time chart.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Start / Stop Values
DBL | start value (1000.0) (DBL) This control defines the start value of a limit which must not be exceeded by the frequency or level applied to the analyzer input. If the the frequency or level exceeds the limit, a measurement is triggered. Valid Range: 0.0 Hz to 125.0 kHz 10.0 uV to 30.0 V 1.0 uFS to 1.0 FS Default Value: 1000.0 Notes: (1) This control is active only if 'start condition' is not set to time tick or time chart.
DBL | stop value (10000.0) (DBL) This control defines the stop value of a limit which must not be exceeded by the frequency or level applied to the analyzer input. If the the frequency or level exceeds the limit, a measurement is triggered. Valid Range: 0.0 Hz to 125.0 kHz 10.0 uV to 30.0 V 1.0 uFS to 1.0 FS Default Value: 10000.0 Notes: (1) This control is active only if 'start condition' is not set to time tick or time chart.
I32 | start/stop value unit (Hz:16) (I32) Sets the start/stop value unit. Valid Range: 0 - V 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - W 7 - mW 8 - uW 9 - FS 10 - %FS 11 - dBFS 12 - LSBs 13 - d% 14 - bits 15 - dBr 16 - Hz (default)
Cluster Min Level
DBL | min level (0.1) (DBL) This control specifies the minimum voltage to be applied to the analyzer input in order to trigger a measurement. Valid Range: 0.01E-3 FS to 1.0 FS 0.01 mV to 30.0 V Default Value: 0.1 V Notes: (1) This control is active only if 'start condition is set to frequency channel 1, 2, frequency sweep channel 1, 2.
I32 | min level unit (V:0) (I32) Sets the minimum level unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - W 7 - mW 8 - uW 9 - FS 10 - %FS 11 - dBFS 12 - LSBs 13 - d% 14 - bits 15 - dBr Notes: (1) This control is active only if 'start condition' is set to frequency channel 1, 2, frequency sweep channel 1, 2.
Cluster Time Tick / Chart
I32 | points (30) (I32) Defines the number of entries to be entered in the measured value buffer. Valid Range: 2 to 1024 Default Value: 30 Notes: (1) This control is active only if 'start condition' is set to time chart or time tick.
DBL | time in sec (1.0) (DBL) Specifies the interval between the single tracings of measured values. Valid Range: 10.0 ms to 2000.0 s Default Value: 1.0 s Notes: (1) This control is active only if 'start condition' is set to time chart or time tick.


RSUPL Config Analyzer Filter User

This VI configures the user-defined filters. The following settings are available:
- filter type
- user filter number
- passband frequency
- passband low frequency
- passband high frequency
- frequency width
- center frequency
- attenuation
- delay

RSUPL Config Analyzer Filter User.vi

DBL attenuation in dB (60.0) (DBL)
Specifies the desired filter attenuation.

Valid Range: 3.0 dB to 120.0 dB

Default Value: 60.0 dB
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Passband / Stopband
DBL | passband freq in Hz (20000.0) (DBL) Specifies the cutoff frequency of the passband range. Valid Range: 0.0 Hz to 125.0 kHz Default Value: 20.0 kHz Notes: (1) This control is active only if 'filter type' is set to low pass or high pass.
DBL | passband low freq in Hz (900.0) (DBL) Specifies the lower cutoff frequency of the passband range. Valid Range: 0.0 Hz to 125.0 kHz Default Value: 900.0 Hz Notes: (1) This control is active only if 'filter type' is set to band pass or band stop.
DBL | passband high freq in Hz (1100.0) (DBL) Specifies the upper cutoff frequency of the passband range. Valid Range: 0.0 Hz to 125.0 kHz Default Value: 1100.0 Hz Notes: (1) This control is active only if 'filter type' is set to band pass or band stop.
DBL | center freq in Hz (16000.0) (DBL) Specifies the center frequency of the passband range. Valid Range: 0.0 Hz to 125.0 kHz Default Value: 16.0 kHz Notes: (1) This control is active only if 'filter type' is set to 1/3 octave filter or octave filter.
DBL | freq width in Hz (500.0) (DBL) Specifies the difference between upper and lower cutoff frequency of the passband range. Valid Range: 0.0 Hz to 125.0 kHz Default Value: 500.0 Hz Notes: (1) This control is active only if 'filter type' is set to notch filter.
Cluster Coefficient File
String | file name ("*.coe") (abc) Specifies a file in which the user filter is stored. Default Value: "*.coe" Notes: (1) Example: "C:\\UPL\\USER\\FILTER1.COE" (2) This control is active only if 'filter type' is set to file defined.
DBL | delay in sec (0.1) (DBL) Sets the settling time of the user-defined filter. Valid Range: 0.0 s to 1.0 s Default Value: 0.1 s Notes: (1) This control is active only if 'filter type' is set to file defined.
Cluster Filter Selection
I32 | filter type (low pass:0) (I32) Selects a filter type. Valid Range: 0 - low pass (default) 1 - high pass 2 - band pass 3 - band stop 4 - notch 5 - 1/3 octave 6 - octave 7 - file defined
I32 | user filter number (1:0) (I32) Specifies the number of a user defined filter. Valid Range: 0 - 1 (default) 1 - 2 2 - 3 3 - 4 4 - 5 5 - 6 6 - 7 7 - 8 8 - 9


RSUPL Config Analyzer Filter Sel

This VI selects filters for analyzer functions. For configuration of filters see the VI RSUPL Config Analyzer Filter User.vi.
The following settings are available:
- filter 1
- filter 2
- filter 3

RSUPL Config Analyzer Filter Sel.vi

I32 filter 1 (off:0) (I32)
Selects the first filter.

Valid Range:
0 - off (default)
1 - user 1
2 - user 2
3 - user 3
4 - user 4
5 - user 5
6 - user 6
7 - user 7
8 - user 8
9 - user 9
10 - A Weighting
11 - C Message
12 - CCITT
13 - CCIR wtd
14 - CCIR unwtd
15 - DEEM 50/15
16 - DEEMPH 50
17 - DEEMPH 75
18 - DEEMPH J.17
19 - RUMBLE wtd
20 - RUMBLE unw
21 - DC Noise HP
22 - CCIR ARM
23 - IEC Tuner
24 - Jitter wtd
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
I32 filter 2 (off:0) (I32)
Selects the second filter.

Valid Range:
0 - off (default)
1 - user 1
2 - user 2
3 - user 3
4 - user 4
5 - user 5
6 - user 6
7 - user 7
8 - user 8
9 - user 9
10 - A Weighting
11 - C Message
12 - CCITT
13 - CCIR wtd
14 - CCIR unwtd
15 - DEEM 50/15
16 - DEEMPH 50
17 - DEEMPH 75
18 - DEEMPH J.17
19 - RUMBLE wtd
20 - RUMBLE unw
21 - DC Noise HP
22 - CCIR ARM
23 - IEC Tuner
24 - Jitter wtd
I32 filter 3 (off:0) (I32)
Selects the third filter.

Valid Range:
0 - off (default)
1 - user 1
2 - user 2
3 - user 3
4 - user 4
5 - user 5
6 - user 6
7 - user 7
8 - user 8
9 - user 9
10 - A Weighting
11 - C Message
12 - CCITT
13 - CCIR wtd
14 - CCIR unwtd
15 - DEEM 50/15
16 - DEEMPH 50
17 - DEEMPH 75
18 - DEEMPH J.17
19 - RUMBLE wtd
20 - RUMBLE unw
21 - DC Noise HP
22 - CCIR ARM
23 - IEC Tuner
24 - Jitter wtd


RSUPL Config Analyzer Single Filter Sel

This VI selects filter for analyzer functions. For configuration of filters see the VI RSUPL Config Analyzer Filter User.vi.

RSUPL Config Analyzer Single Filter Sel.vi

I32 filter number (1) (I32)
Specifies the number of a filter.

Valid Range:
1 to 3

Default Value: 1
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
I32 filter (off:0) (I32)
Selects the filter.

Valid Range:
0 - off (default)
1 - user 1
2 - user 2
3 - user 3
4 - user 4
5 - user 5
6 - user 6
7 - user 7
8 - user 8
9 - user 9
10 - A Weighting
11 - C Message
12 - CCITT
13 - CCIR wtd
14 - CCIR unwtd
15 - DEEM 50/15
16 - DEEMPH 50
17 - DEEMPH 75
18 - DEEMPH J.17
19 - RUMBLE wtd
20 - RUMBLE unw
21 - DC Noise HP
22 - CCIR ARM
23 - IEC Tuner
24 - Jitter wtd


RSUPL Config Analyzer Limit

This VI enables and configures the limit checking capability of the instrument. The following settings are available:
- limit check mode
- limit check object
- upper limit
- filename upper limit value
- upper limit value
- upper limit unit
- lower limit
- filename lower limit value
- lower limit value
- lower limit unit

RSUPL Config Analyzer Limit.vi

I32 limit check mode (off:0) (I32)
Enables limit checking and selects the limit to check.

Valid Range:
0 - off (default)
1 - limit lower
2 - limit upper
3 - limit lower&upper
I32 limit check object (trace 1:0) (I32)
Selects the trace to check.

Valid Range:
0 - trace 1 (default)
1 - trace 2
2 - trace 1&2
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Lower Limit
Boolean | lower limit (value:F) (TF) Determines whether a single value or a file with limit curve is used for checking the lower limit. Valid Range: F - value (default) T - file
String | file name lower limit ("*.llw") (abc) Specifies the file which contains the lower limit curve. Default Value: "*.llw" Notes: (1) Example: "C:\\UPL\\USER\\FILE1.LLW" (2) This control is active only if 'lower limit' is set to file.
DBL | lower limit value (0.05) (DBL) Sets the lower limit value. Valid Range: -1.0E9 V to 1.0E9 V Default Value: 0.05 V Notes: (1) This control is active only if 'lower limit' is set to value.
I32 | lower limit unit (V:0) (I32) Sets the lower limit unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - W 10 - dW 11 - d%W 12 - %V/Vr 13 - %P/Pr 14 - P/Pr 15 - FS 16 - %FS 17 - dBFS 18 - d% 19 - LSBs 20 - dBr 21 - bits 22 - UI 23 - %UI 24 - dBUI 25 - ppm 26 - ns 27 - UIr 28 - dB 29 - % Notes: (1) This control is active only if 'lower limit' is set to value.
Cluster Upper Limit
Boolean | upper limit (value:F) (TF) Determines whether a single value or a file with limit curve is used for checking the upper limit. Valid Range: F - value (default) T - file
String | file name upper limit ("*.lup") (abc) Specifies the file which contains the upper limit curve. Default Value: "*.lup" Notes: (1) Example: "C:\\UPL\\USER\\FILE1.LUP" (2) This control is active only if 'upper limit' is set to file.
DBL | upper limit value (0.5) (DBL) Sets the upper limit value. Valid Range: -1.0E9 V to 1.0E9 V Default Value: 0.5 V Notes: (1) This control is active only if 'upper limit' is set to value.
I32 | upper limit unit (V:0) (I32) Sets the upper limit unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - V/Vr 7 - d%V 8 - dV 9 - W 10 - dW 11 - d%W 12 - %V/Vr 13 - %P/Pr 14 - P/Pr 15 - FS 16 - %FS 17 - dBFS 18 - d% 19 - LSBs 20 - dBr 21 - bits 22 - UI 23 - %UI 24 - dBUI 25 - ppm 26 - ns 27 - UIr 28 - dB 29 - % Notes: (1) This control is active only if 'upper limit' is set to value.


RSUPL Config Analyzer Protocol Anl

This VI configures protocol analysis. The following settings are available:
- source
- protocol format
- filename

RSUPL Config Analyzer Protocol Anl.vi

I32 source (chan status left:0) (I32)
Selects the data type.

Valid Range:
0 - channel status left (default)
1 - channel status right
2 - user left
3 - user right
I32 protocol format (binary:0) (I32)
Selects the interpretation mode.

Valid Range:
0 - binary (default)
1 - hexadecimal
2 - ASCII
3 - file defined

Notes:
(1) This control is active only if 'source' is set to user left or user right.
String file name ("*.pac") (abc)
Specifies the interpretation file for user data.

Default Value: "*.pac"

Notes:
(1) Example: "C:\\UPL\\USER\\FILE1.PAC"
(2) This control is active only if 'source' is set to channel status left or channel status right.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Config Analyzer Func RMS S N

This VI enables and configures RMS & S/N measurement.
The following settings are available:
- s/n measurement
- measurement time
- unit channel 1
- unit channel 2
- trigger level
- reference
- notch gain
- notch frequency

RSUPL Config Analyzer Func RMS S N.vi

Boolean s/n measure (off:F) (TF)
Enables or disables signal-to-noise measurement.

Valid Range:
F - off (default)
T - on

Notes:
(1) If set to on, the channel unit must be set to dB.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster Notch Filter
I32 | notch gain (off:0) (I32) This control selects the notch gain. Valid Range: 0 - off (default) 1 - 0 dB 2 - 12 dB auto 3 - 30 dB auto
Boolean | notch freq (value:F) (TF) This control selects the notch frequency mode. Valid Range: F - value (default) T - generator track
DBL | notch freq value in Hz (10.0) (DBL) This control selects the notch frequency value in Hz. Valid Range: 10.0 to 22500.0 Hz Default Value: 10.0 Hz Notes: (1) This controls has an effect only if the control 'notch freq' is set to value.
Cluster Reference
I32 reference (value:0) (I32)
Sets the reference value.

Valid Range:
0 - value (default)
1 - store channel 1
2 - store channel 2
3 - store
4 - measure channel 1
5 - measure channel 2
6 - generator track

Notes:
(1) Value - the reference value is specified by control Reference Value.
(2) Store Channel 1, 2 - the current level measurement result of channel 1 or 2 is stored when running this function and set as a new reference value. This selections are available only with two-channel measurement.
(3) Store - the result of a one-channel measurement is stored when running this function. The reference value does not change during the measurement. This selection is available only with one-channel measurement.
(4) Measure Channel 1, 2 - each measurement result of channel 1 or 2 is immediately stored as the reference value. This selections are available only with two-channel measurement.
(5) Generator Track - the presently valid generator voltage and each newly set generator voltage are stored as the reference value.
DBL reference value (1.0) (DBL)
Sets the reference value.

Valid Range:
-100.0 FS to 100.0 FS
-1000.0 V to 1000.0 V

Default Value: 1.0 V

Notes:
(1) This control is active only if 'reference' is set to value.
I32 reference value unit (V:0) (I32)
Sets the reference value unit.

Valid Range:
0 - V (default)
1 - mV
2 - uV
3 - dBV
4 - dBu
5 - dBm
6 - W
7 - mW
8 - uW
9 - FS
10 - %FS
11 - dBFS
12 - LSBs
13 - d%
14 - bits
15 - dBr
16 - UI
17 - %UI
18 - dBUI
19 - ppm
20 - ns
21 - UIr

Notes:
(1) This control is active only if 'reference' is set to value.
Cluster Measurement Units
I32 | unit chan 1 (V:0) (I32) Selects the unit for channel 1. Valid Range: 0 - V (default) 1 - dBV 2 - dBu 3 - dBm 4 - W 5 - d%V 6 - dV 7 - V/Vr 8 - %V/Vr 9 - d%W 10 - dW 11 - P/Pr 12 - %P/Pr 13 - FS 14 - %FS 15 - dBFS 16 - LSBs 17 - d% 18 - bits 19 - dBr 20 - UI 21 - %UI 22 - dBUI 23 - ppm 24 - ns 25 - UIr 26 - dB
I32 | unit chan 2 (V:0) (I32) Selects the unit for channel 2. Valid Range: 0 - V (default) 1 - dBV 2 - dBu 3 - dBm 4 - W 5 - d%V 6 - dV 7 - V/Vr 8 - %V/Vr 9 - d%W 10 - dW 11 - P/Pr 12 - %P/Pr 13 - FS 14 - %FS 15 - dBFS 16 - LSBs 17 - d% 18 - bits 19 - dBr 20 - UI 21 - %UI 22 - dBUI 23 - ppm 24 - ns 25 - UIr 26 - dB
Cluster Trigger Level
DBL | trigger level (0.0) (DBL) Sets the trigger level for triggered measurement mode. Valid Range: -240.0 dB to 0.0 dB Default Value: 0.0 dB Notes: (1) This control is active only if 'measurement time' is set to triggered.
Boolean | trigger level unit (%:F) (TF) Selects the trigger level unit. Valid Range: F - % T - dB (default) Notes: (1) This control is active only if 'measurement mode' is set to triggered.
Cluster Measurement Time
I32 | meas time (auto:3) (I32) Sets the measurement time, which serves to match the measurement rate to the signal frequency. Valid Range: 0 - value 1 - triggered 2 - auto fast 3 - auto (default) 4 - generator track Notes: (1) Value - numeric entry of the desired measuring time by means of Measurement Time Value control. (2) Triggered - a single measurement with selectable measuring time is performed as soon as the signal first exceeds a trigger threshold. This setting is not valid with digital jitter/phase and common/inp modes. (3) Auto Fast - automatic matching of the measuring time to the signal frequency with consideration of the signal period. Maximum algorithmic error 1%. (4) Auto - automatic matching of the measuring time to the signal frequency with consideration of the signal period. Maximum algorithmic error 0.001%. (5) Generator Track - measurement across one period of the generator signal.
DBL | meas time value in s (0.3) (DBL) Sets the measurement time. Valid Range: Analog Analyzer 22kHz: 100.0 us to 10.0 s Analog Analyzer 110kHz: 100.0 us to 266.6 s Digital Analyzer: 100.0 us to 10.0 s Default Value: 0.3 s Notes: (1) This control is active only if 'measurement time' is set to value.


RSUPL Config Analyzer Func RMS Sel

This VI enables and configures RMS selective measurement.
The following settings are available:
- measurement time
- unit channel 1
- unit channel 2
- frequency mode
- reference
- notch gain
- bandwidth

RSUPL Config Analyzer Func RMS Sel.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Measurement Units
I32 | unit chan 1 (V:0) (I32) Selects the unit for channel 1. Valid Range: 0 - V (default) 1 - dBV 2 - dBu 3 - dBm 4 - W 5 - d%V 6 - dV 7 - V/Vr 8 - %V/Vr 9 - d%W 10 - dW 11 - P/Pr 12 - %P/Pr 13 - FS 14 - %FS 15 - dBFS 16 - LSBs 17 - d% 18 - bits 19 - dBr 20 - UI 21 - %UI 22 - dBUI 23 - ppm 24 - ns 25 - UIr 26 - dB
I32 | unit chan 2 (V:0) (I32) Selects the unit for channel 2. Valid Range: 0 - V (default) 1 - dBV 2 - dBu 3 - dBm 4 - W 5 - d%V 6 - dV 7 - V/Vr 8 - %V/Vr 9 - d%W 10 - dW 11 - P/Pr 12 - %P/Pr 13 - FS 14 - %FS 15 - dBFS 16 - LSBs 17 - d% 18 - bits 19 - dBr 20 - UI 21 - %UI 22 - dBUI 23 - ppm 24 - ns 25 - UIr 26 - dB
Cluster Reference
I32 reference (value:0) (I32)
Sets the reference value.

Valid Range:
0 - value (default)
1 - store channel 1
2 - store channel 2
3 - store
4 - measure channel 1
5 - measure channel 2
6 - generator track

Notes:
(1) Value - the reference value is specified by control Reference Value.
(2) Store Channel 1, 2 - the current level measurement result of channel 1 or 2 is stored when running this function and set as a new reference value. This selections are available only with two-channel measurement.
(3) Store - the result of a one-channel measurement is stored when running this function. The reference value does not change during the measurement. This selection is available only with one-channel measurement.
(4) Measure Channel 1, 2 - each measurement result of channel 1 or 2 is immediately stored as the reference value. This selections are available only with two-channel measurement.
(5) Generator Track - the presently valid generator voltage and each newly set generator voltage are stored as the reference value.
DBL reference value (1.0) (DBL)
Sets the reference value.

Valid Range:
-100.0 FS to 100.0 FS
-1000.0 V to 1000.0 V

Default Value: 1.0 V

Notes:
(1) This control is active only if 'reference' is set to value.
I32 reference value unit (V:0) (I32)
Sets the reference value unit.

Valid Range:
0 - V (default)
1 - mV
2 - uV
3 - dBV
4 - dBu
5 - dBm
6 - W
7 - mW
8 - uW
9 - FS
10 - %FS
11 - dBFS
12 - LSBs
13 - d%
14 - bits
15 - dBr
16 - UI
17 - %UI
18 - dBUI
19 - ppm
20 - ns
21 - UIr

Notes:
(1) This control is active only if 'reference' is set to value.
Cluster Filters
I32 | notch gain (off:0) (I32) Enables the notch filter and sets its gain. Valid Range: 0 - off (default) 1 - 0 dB 2 - 12 dB auto 3 - 30 dB auto Notes: (1) Notch filter is available only in analog analyzer with bandwidth set to any of the bandpass settings.
I32 | bandwidth (bandpass 1%:0) (I32) Sets the bandwidth of the band filter. Valid Range: 0 - bandpass 1% (default) 1 - bandpass 3% 2 - bandpass 1/3 oct 3 - bandpass 1/12 oct 4 - bandpass fix 5 - bandstop 1% 6 - bandstop 3% 7 - bandstop 1/3 oct 8 - bandstop 1/12 oct 9 - bandstop fix
DBL | bandwidth value in Hz (100.0) (DBL) Sets the band width of the filter. Valid Range: analog analyzer 22 kHz: 9.9 Hz to 16.0 kHz analog analyzer 110 kHz: 70.4 Hz to 113.8 kHz digital analyzer: sample freq/4800 to sample freq/3 Default Value: 100.0 Hz Notes: (1) This control is active only if 'bandwidth' is set to bandpass fix or bandstop fix.
Cluster Frequency
DBL | frequency value in Hz (1000.0) (DBL) Sets the center frequency value. Valid Range: 0.0 Hz to 110.0 kHz Default Value: 1.0 kHz Notes: (1) This control is active only if 'frequency mode' is set to fix.
I32 | freq mode (gen track:1) (I32) Specifies the way in which the center frequency of the band filter or the search frequency of the analyzer is to be set. Valid Range: 0 - fix 1 - generator track (default) 2 - frequency channel 1 3 - frequency channel 2 Notes: (1) Fix - the frequency is set by means of control Frequency Value. (2) Generator Track - generator frequency is used as the set frequency. (3) Frequency Channel 1, 2 - the last result of the frequency measurement in channel 1 or 2 is used.
DBL | Gen Tracking Factor (1.0) (DBL) This control selects the factor that the generator's frequency is multiplied with to obtain the bandpass / -stop center frequency. Valid Range: 1.0 to 20.0 Default Value: 1.0 Notes: (1) This control has an effect only with Freq Mode set to 'gen track'.
Cluster Measurement Time
I32 | meas time (auto fast:2) (I32) Sets the measurement time, which serves to match the measurement rate to the signal frequency. Valid Range: 0 - value 1 - triggered 2 - auto fast 3 - auto (default) 4 - generator track Notes: (1) Value - numeric entry of the desired measuring time by means of Measurement Time Value control. (2) Triggered - a single measurement with selectable measuring time is performed as soon as the signal first exceeds a trigger threshold. This setting is not valid with digital jitter/phase and common/inp modes. (3) Auto Fast - automatic matching of the measuring time to the signal frequency with consideration of the signal period. Maximum algorithmic error 1%. (4) Auto - automatic matching of the measuring time to the signal frequency with consideration of the signal period. Maximum algorithmic error 0.001%. (5) Generator Track - measurement across one period of the generator signal.
DBL | meas time value in s (0.3) (DBL) Sets the measurement time. Valid Range: analog analyzer 22kHz: 100.0 us to 10.0 s analog analyzer 110kHz: 100.0 us to 266.6 s digital analyzer: 100.0 us to 10.0 s Default Value: 0.3 s Notes: (1) This control is active only if 'measurement time' is set to value.


RSUPL Config Analyzer Func RMS Sweep

This VI enables and configures RMS Sweep measurement.
The following settings are available:
- sweep control
- start frequency
- stop frequency
- spacing
- sweep points
- step width
- sweep data file

RSUPL Config Analyzer Func RMS Sweep.vi

I32 spacing (lin points:0) (I32)
Selects the spacing of the sweep range.

Valid Range:
0 - linear points (default)
1 - logarithmic points
2 - linear steps
3 - logarithmic steps

Notes:
(1) This control is active only if 'sweep control' is set to auto sweep or manual sweep.
(2) Linear Points - the sweep range between Start Frequency and Stop Frequency is linearly spaced by a number of points entered in Points/Step Width. The step size is:

step [Hz] = (stop freq [Hz] - start freq [Hz]) / (points - 1)

(3) Logarithmic Points - the sweep range between Start Frequency and Stop Frequency is logarithmically spaced by a number of points entered in Points/Step Width. The step size is:

step [Hz] = (stop freq [Hz] / start freq [Hz]) exp (1 / poinst - 1)

(4) Linear Steps - the sweep range between Start Frequency and Stop Frequency is spaced in frequency intervals determined by the linear step width entered in Points/Step Width. The number of points is:

points = abs(stop freq [Hz] - start freq [Hz]) / step [Hz] + 1

(5) Logarithmic Steps - the sweep range between Start Frequency and Stop Frequency is spaced in a logharitmic step size entered in Points/Step Width.
I32 sweep control (off:0) (I32)
Enables the sweep and defines the way the band center frequency will be swept.

Valid Range:
0 - off (default)
1 - auto sweep
2 - auto list
3 - manual sweep
4 - manual list
5 - multisine

Notes:
(1) Auto Sweep - the sweep runs automatically after the first trigger. The sweep parameter data are calculated from the user specification (start, stop etc.)
(2) Auto List - the sweep runs automatically after the first trigger. The sweep parameter data are read from a specified file.
(3) Manual Sweep - the sweep is controlled by means of function Step. The sweep parameter data are calculated from the user specification (start, stop etc.)
(4) Manual List - the sweep is controlled by means of function Step. The sweep parameter data are read from a specified file.
(5) Multisine - the band center frequency is subsequently set to the multisine frequencies entered in the generator function Multisine.
String file name "*.spf" (abc)
Specifies the sweep list data file.

Default Value: "*.spf"

Notes:
(1) Example: "C:\\UPL\\USER\\SWEEP1.SPF"
(2) This control is active only if 'sweep control' is set to auto list or manual list.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster Sweep Parameters
DBL | start frequency in Hz (100.0) (DBL) Sets the start frequency value of the sweep. Valid Range: 10.0 Hz to 125.0 kHz Default Value: 100.0 Hz
DBL | stop frequency in Hz (20000.0) (DBL) Sets the stop frequency value of the sweep. Valid Range: 10.0 Hz to 125.0 kHz Default Value: 20.0 kHz
DBL | points/step width (30.0) (DBL) Enters the number of points or step width of a sweep. The function of this control depends on the selection made in the control Spacing. Valid Range: points: 2 to 1024 step width: 2.0 Hz to 110.0 kHz Default Value: 30.0 Hz Notes: (1) This control is active only if 'sweep control' is set to auto sweep or manual sweep.
I32 | step unit (Hz:0) (I32) Sets the unit of a step. Valid Range: 0 - Hz 1 - kHz 2 - dHz 3 - dkHz 4 - f/fr 5 - d%Hz 6 - Toct 7 - Oct 8 - Dec Notes: (1) This control is active only if 'sweep control' is set to auto sweep or manual sweep and spacing is set to linear points or logarithmic points.


RSUPL Config Analyzer Func Peak

This VI enables and configures Peak & S/N measurement. This function is available in the analog analyzer 22 kHz and in the digital analyzer.
The following settings are available:
- s/n measurement
- meas mode
- unit channel 1
- unit channel 2
- interval time
- reference

RSUPL Config Analyzer Func Peak.vi

I32 meas mode (peak +:0) (I32)
Selects the measurement mode.

Valid Range:
0 - PK + (default)
1 - PK -
2 - PH to PK
3 - PK abs
Boolean s/n measure (off:F) (TF)
Enables or disables signal-to-noise measurement.

Valid Range:
F - off (default)
T - on
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster Reference
I32 reference (value:0) (I32)
Sets the reference value.

Valid Range:
0 - value (default)
1 - store channel 1
2 - store channel 2
3 - store
4 - measure channel 1
5 - measure channel 2
6 - generator track

Notes:
(1) Value - the reference value is specified by control Reference Value.
(2) Store Channel 1, 2 - the current level measurement result of channel 1 or 2 is stored when running this function and set as a new reference value. This selections are available only with two-channel measurement.
(3) Store - the result of a one-channel measurement is stored when running this function. The reference value does not change during the measurement. This selection is available only with one-channel measurement.
(4) Measure Channel 1, 2 - each measurement result of channel 1 or 2 is immediately stored as the reference value. This selections are available only with two-channel measurement.
(5) Generator Track - the presently valid generator voltage and each newly set generator voltage are stored as the reference value.
DBL reference value (1.0) (DBL)
Sets the reference value.

Valid Range:
-100.0 FS to 100.0 FS
-1000.0 V to 1000.0 V

Default Value: 1.0 V

Notes:
(1) This control is active only if 'reference' is set to value.
I32 reference value unit (V:0) (I32)
Sets the reference value unit.

Valid Range:
0 - V (default)
1 - mV
2 - uV
3 - dBV
4 - dBu
5 - dBm
6 - W
7 - mW
8 - uW
9 - FS
10 - %FS
11 - dBFS
12 - LSBs
13 - d%
14 - bits
15 - dBr
16 - UI
17 - %UI
18 - dBUI
19 - ppm
20 - ns
21 - UIr

Notes:
(1) This control is active only if 'reference' is set to value.
Cluster Interval Time
I32 | interval time (fixed 50 ms:1) (I32) Sets the monitoring interval for peak value detection. Valid Range: 0 - value 1 - fixed 50 ms (default) 2 - fixed 200 ms 3 - fixed 1000 ms Notes: (1) The fixed values 50 ms and 1000ms are not valid in the analyzer digital jitter/phase and common/inp modes.
DBL | interval time value in s (0.2) (DBL) Sets the interval time. Valid Range: 20.0 ms to 10.0 s Default Value: 0.2 s Notes: (1) This control is active only if 'interval time' is set to value.
Cluster Measurement Units
I32 | unit chan 1 (V:0) (I32) Selects the unit for channel 1. Valid Range: 0 - V (default) 1 - dBV 2 - dBu 3 - dBm 4 - W 5 - d%V 6 - dV 7 - V/Vr 8 - %V/Vr 9 - d%W 10 - dW 11 - P/Pr 12 - %P/Pr 13 - FS 14 - %FS 15 - dBFS 16 - LSBs 17 - d% 18 - bits 19 - dBr 20 - UI 21 - %UI 22 - dBUI 23 - ppm 24 - ns 25 - UIr 26 - dB
I32 | unit chan 2 (V:0) (I32) Selects the unit for channel 2. Valid Range: 0 - V (default) 1 - dBV 2 - dBu 3 - dBm 4 - W 5 - d%V 6 - dV 7 - V/Vr 8 - %V/Vr 9 - d%W 10 - dW 11 - P/Pr 12 - %P/Pr 13 - FS 14 - %FS 15 - dBFS 16 - LSBs 17 - d% 18 - bits 19 - dBr 20 - UI 21 - %UI 22 - dBUI 23 - ppm 24 - ns 25 - UIr 26 - dB


RSUPL Config Analyzer Func Quasi Peak

This VI enables and configures Quasi-Peak & S/N measurement. This function is available in the analog analyzer 22 kHz and in the digital analyzer.
The following settings are available:
- s/n mesurement
- unit channel 1
- unit channel 2
- interval time
- reference
- notch gain
- notch freq

RSUPL Config Analyzer Func Quasi Peak.vi

Boolean s/n measure (off:F) (TF)
Enables or disables signal-to-noise measurement.

Valid Range:
F - off (default)
T - on

Notes:
(1) If set to on, the onlu valid channel unit is dB.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Measurement Units
I32 | unit chan 1 (V:0) (I32) Selects the unit for channel 1. Valid Range: 0 - V (default) 1 - dBV 2 - dBu 3 - dBm 4 - W 5 - d%V 6 - dV 7 - V/Vr 8 - %V/Vr 9 - d%W 10 - dW 11 - P/Pr 12 - %P/Pr 13 - FS 14 - %FS 15 - dBFS 16 - LSBs 17 - d% 18 - bits 19 - dBr 20 - UI 21 - %UI 22 - dBUI 23 - ppm 24 - ns 25 - UIr 26 - dB
I32 | unit chan 2 (V:0) (I32) Selects the unit for channel 2. Valid Range: 0 - V (default) 1 - dBV 2 - dBu 3 - dBm 4 - W 5 - d%V 6 - dV 7 - V/Vr 8 - %V/Vr 9 - d%W 10 - dW 11 - P/Pr 12 - %P/Pr 13 - FS 14 - %FS 15 - dBFS 16 - LSBs 17 - d% 18 - bits 19 - dBr 20 - UI 21 - %UI 22 - dBUI 23 - ppm 24 - ns 25 - UIr 26 - dB
Cluster Reference
I32 reference (value:0) (I32)
Sets the reference value.

Valid Range:
0 - value (default)
1 - store channel 1
2 - store channel 2
3 - store
4 - measure channel 1
5 - measure channel 2
6 - generator track

Notes:
(1) Value - the reference value is specified by control Reference Value.
(2) Store Channel 1, 2 - the current level measurement result of channel 1 or 2 is stored when running this function and set as a new reference value. This selections are available only with two-channel measurement.
(3) Store - the result of a one-channel measurement is stored when running this function. The reference value does not change during the measurement. This selection is available only with one-channel measurement.
(4) Measure Channel 1, 2 - each measurement result of channel 1 or 2 is immediately stored as the reference value. This selections are available only with two-channel measurement.
(5) Generator Track - the presently valid generator voltage and each newly set generator voltage are stored as the reference value.
DBL reference value (1.0) (DBL)
Sets the reference value.

Valid Range:
-100.0 FS to 100.0 FS
-1000.0 V to 1000.0 V

Default Value: 1.0 V

Notes:
(1) This control is active only if 'reference' is set to value.
I32 reference value unit (V:0) (I32)
Sets the reference value unit.

Valid Range:
0 - V (default)
1 - mV
2 - uV
3 - dBV
4 - dBu
5 - dBm
6 - W
7 - mW
8 - uW
9 - FS
10 - %FS
11 - dBFS
12 - LSBs
13 - d%
14 - bits
15 - dBr
16 - UI
17 - %UI
18 - dBUI
19 - ppm
20 - ns
21 - UIr

Notes:
(1) This control is active only if 'reference' is set to value.
Cluster Interval Time
Boolean | interval time (fixed 3s:T) (I32) Sets the monitoring interval for peak value detection. Valid Range: 0 - value 1 - fixed 50 ms (default) 2 - fixed 200 ms 3 - fixed 1000 ms Notes: (1) The fixed values 50 ms and 1000ms are not valid in the analyzer digital jitter/phase and common/inp modes.
DBL | interval time value in s (0.2) (DBL) Sets the interval time. Valid Range: 20.0 ms to 10.0 s Default Value: 0.2 s Notes: (1) This control is active only if 'interval time' is set to value.
Cluster Notch Filter
I32 | notch gain (off:0) (I32) This control selects the notch gain. Valid Range: 0 - off (default) 1 - 0 dB 2 - 12 dB auto 3 - 30 dB auto
Boolean | notch freq (value:F) (TF) This control selects the notch frequency mode. Valid Range: F - value (default) T - generator track
DBL | notch freq value in Hz (10.0) (DBL) This control selects the notch frequency value in Hz. Valid Range: 10.0 to 22500.0 Hz Default Value: 10.0 Hz Notes: (1) This controls has an effect only if the control 'notch freq' is set to value.


RSUPL Config Analyzer Func DC

This VI enables and configures the DC voltage measurement.
The following settings are available:
- unit of channel 1
- unit of channel 2
- measurement time
- reference

RSUPL Config Analyzer Func DC.vi

Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Valid Range: T: Error F: No Error (default)
I32 | code code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message. Valid Range: Not Applicable Default:0
String | source source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred. Default: Empty String
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Valid Range: T: Error F: No Error (default)
I32 | code code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message. Valid Range: Not Applicable Default:0
String | source source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred. Default: Empty String
Cluster Reference
I32 reference (value:0) (I32)
Sets the reference value.

Valid Range:
0 - value (default)
1 - store channel 1
2 - store channel 2
3 - store
4 - measure channel 1
5 - measure channel 2
6 - generator track

Notes:
(1) Value - the reference value is specified by control Reference Value.
(2) Store Channel 1, 2 - the current level measurement result of channel 1 or 2 is stored when running this function and set as a new reference value. This selections are available only with two-channel measurement.
(3) Store - the result of a one-channel measurement is stored when running this function. The reference value does not change during the measurement. This selection is available only with one-channel measurement.
(4) Measure Channel 1, 2 - each measurement result of channel 1 or 2 is immediately stored as the reference value. This selections are available only with two-channel measurement.
(5) Generator Track - the presently valid generator voltage and each newly set generator voltage are stored as the reference value.
DBL reference value (1.0) (DBL)
Sets the reference value.

Valid Range:
-100.0 FS to 100.0 FS
-1000.0 V to 1000.0 V

Default Value: 1.0 V

Notes:
(1) This control is active only if 'reference' is set to value.
I32 reference value unit (V:0) (I32)
Sets the reference value unit.

Valid Range:
0 - V (default)
1 - mV
2 - uV
3 - dBV
4 - dBu
5 - dBm
6 - W
7 - mW
8 - uW
9 - FS
10 - %FS
11 - dBFS
12 - LSBs
13 - d%
14 - bits
15 - dBr

Notes:
(1) This control is active only if 'reference' is set to value.
Cluster Measurement Time
Boolean | meas time (fixed:T) (TF) Sets the integration time relative to the signal period of the AC voltage on which the DC voltage may be superposed. Valid Range: F - value T - fixed 200 ms (default)
DBL | meas time value in s (0.3) (DBL) Sets the interval time. Valid Range: 1.0 ms to 1.5 s Default Value: 0.3 s Notes: (1) This control is active only if 'interval time' is set to value.
Cluster Measurement Units
I32 | unit chan 1 (V:0) (I32) Selects the unit for channel 1. Valid Range: 0 - V 1 - dBV 2 - dBu 3 - dBm 4 - W 5 - d%V 6 - dV 7 - V/Vr 8 - %V/Vr 9 - d%W 10 - dW 11 - P/Pr 12 - %P/Pr 13 - FS 14 - %FS 15 - dBFS 16 - LSBs 17 - d% 18 - bits 19 - dBr
I32 | unit chan 2 (V:0) (I32) Selects the unit for channel 2. Valid Range: 0 - V (default) 1 - dBV 2 - dBu 3 - dBm 4 - W 5 - d%V 6 - dV 7 - V/Vr 8 - %V/Vr 9 - d%W 10 - dW 11 - P/Pr 12 - %P/Pr 13 - FS 14 - %FS 15 - dBFS 16 - LSBs 17 - d% 18 - bits 19 - dBr


RSUPL Config Analyzer Func THD

This VI enables and configures the Total Harmonic Distortion measurement. This function is available in digital generator only with measurement mode set to audio data.
The following settings are available:
- fundamental frequency
- channel unit
- measurement mode
- dynamic mode
- reference

RSUPL Config Analyzer Func THD.vi

Boolean dynamic mode (precision:F) (TF)
Determines the possible dynamic of the measurement result and thus the measurement rate.

Valid Range:
F - precision (default)
T - fast

Notes:
(1) This control is active only in analog analyzer.
(2) Precision - the measurement is performed with high dynamic and with the analog notch filter cut in; the measurement time increases.
(3) Fast - fast measurement with less dynamic.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Reference
DBL | reference value (1.0) (DBL) Sets the reference value. Valid Range: -100.0 FS to 100.0 FS -1000.0 V to 1000.0 V Default Value: 1.0 V Notes: (1) This control is valid only if the control 'meas mode' is set to: level select di, level even di, level odd di or level all di.
I32 | reference value unit (V:0) (I32) Sets the reference value unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - W 7 - mW 8 - uW 9 - FS 10 - %FS 11 - dBFS 12 - LSBs 13 - d% 14 - bits 15 - dBr Notes: (1) This control is valid only if the control 'meas mode' is set to: level select di, level even di, level odd di or level all di.
Cluster Fundamental
Boolean | fundamental freq (auto:F) (TF) Specifies how the fundamental frequency is to be determined. Valid Range: F - auto (default) T - value
DBL | fundamental in Hz (10000.0) (DBL) Sets the fundamental frequency. Valid Range: analog analyzer 22kHz: 5.8 Hz to 21.9 kHz analog analyzer 110kHz: 41.7 Hz to 125.0 kHz digital analyzer: sample freq/8192 to sample freq * 117/256 Default Value: 10.0 kHz Notes: (1) This control is active only if 'fundamental frequency' is set to value.
Cluster Harmonics
I32 | meas mode (all di:3) (I32) Specifies the harmonics to be measured. Valid Range: 0 - select di 1 - all even di 2 - all odd di 3 - all di (default) 4 - level select di 5 - level even di 6 - level odd di 7 - level all di Notes: (1) Select di, All Even di, All Odd di, All di - a specified combination of harmonic distortion d2 to d9. The measurement result is the root from square sum of the selected harmonic distortion referred to the total RMS value. (2) Level Select di, Level Even di, Level Odd di, Level All di - a specified combination of harmonic distortion d2 to d9. The measurement result is the root from square sum of the selected harmonic distortion displayed as RMS value.
I32 | harmonics (0) (I32) Selects the harmonics to measure. Valid Range: 0 to 255 Default Value: 0 Notes: (1) The harmonics are input as an integer data word value in which a bit for a harmonic is set. data bit: harmonic: weighting: ---------------------------------------------------- MSB di9 128 di8 64 di7 32 di6 16 di5 8 di4 4 di3 2 LSB di2 1 Example: di1, di3, di5, and di7 data word = 10101010 weighting = 2 + 8 + 32 + 128 decimal equivalent = 170 (2) This control is active only if 'measurement mode' is set to select di or level select di.
Boolean Meas Unit (dB:F) (TF)
Selects the THD measurement unit.

Valid range:
T - %
F - dB

Default Value:
F - dB


RSUPL Config Analyzer Func THD + Noise

This VI enables and configures the Total Harmonics Distortion and noise measurement. This function is available in digital generator only with measurement mode set to audio data.
The following settings are available:
- mode
- fundamental frequency
- channel unit
- measurement mode
- dynamic mode
- lower frequency limit
- upper frequency limit
- rejection
- reference value

RSUPL Config Analyzer Func THD + Noise.vi

I32 Meas Unit (dB:21) (I32)
Selects the channel unit.

Valid Range:
0 - V
1 - dBV
2 - dBu
3 - dBm
4 - W
5 - d%V
6 - dV
7 - V/Vr
8 - %V/Vr
9 - d%W
10 - dW
11 - P/Pr
12 - %P/Pr
13 - FS
14 - %FS
15 - dBFS
16 - LSBs
17 - d%
18 - bits
19 - dBr
20 - %
21 - dB (default)

Notes:
(1) Use unit dB or % if 'meas mode' is set to: thd + noise, sinad, noise. Any other unit is not valid in the listed modes.
(2) Units dB and % are not valid if the control 'meas mode' is set to: level thd + noise, level noise.
Boolean dynamic mode (precision:F) (TF)
Determines the possible dynamic of the measurement result and thus the measurement rate.

Valid Range:
F - precision (default)
T - fast

Notes:
(1) This control is active only in analog analyzer.
(2) Precision - the measurement is performed with high dynamic and with the analog notch filter cut in; the measurement time increases.
(3) Fast - fast measurement with less dynamic.
I32 meas mode (THD +:0) (I32)
Selects the measurement mode.

Valid Range:
0 - THD + noise (default)
1 - SINAD
2 - noise
3 - level THD + noise
4 - level noise

Notes:
(1) THD + Noise - the THD including noise is measured; the result is the root from the square sum of the selected harmonic and the noise voltage referred to the total RMS value.
(2) SINAD - like (1), displayed as reciprocal value.
(3) Noise - only noise is measured; the result is the noise voltage referred to the total RMS value.
(4) Level THD + Noise - the THD including noise is measured; the result is the root from the square sum of the selected harmonic and the noise voltage; display as RMS value.
(5) Level Noise - only noise is measured; the result is the noise voltage displayed as RMS value.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster Fundamental
Boolean | fundamental freq (auto:F) (TF) Specifies how the fundamental frequency is to be determined. Valid Range: F - auto (default) T - value
DBL | fundamental in Hz (10000.0) (DBL) Sets the fundamental frequency. Valid Range: analog analyzer 22kHz: 5.8 Hz to 21.9 kHz analog analyzer 110kHz: 41.7 Hz to 125.0 kHz digital analyzer: sample freq/8192 to sample freq * 117/256 Default Value: 10.0 kHz Notes: (1) This control is active only if 'fundamental frequency' is set to value.
Boolean | rejection (narrow:F) (TF) Selects the type of rejection. Valid Range: F - narrow (default) T - wide Notes: (1) This control is active only in analog analyzer and with Dynamic Mode set to 'fast'. (2) Narrow - the fundamental is suppressed with an extremely narrow notch filter. Thus, the distortion and noise measurement range extends very close to the carrier. (3) Wide - an additional two-pole notch filter is inserted, yielding an overall characteristic similar to conventional analog instruments. The measured noise values are lower than with narrow rejection, since anharmonic components close to the carrier are also suppressed.
Cluster Reference
DBL | reference value (1.0) (DBL) Sets the reference value. Valid Range: -100.0 FS to 100.0 FS -1000.0 V to 1000.0 V Default Value: 1.0 V Notes: (1) This control is valid only if the control 'meas mode' is set to: level select di, level even di, level odd di or level all di.
I32 | reference value unit (V:0) (I32) Sets the reference value unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - W 7 - mW 8 - uW 9 - FS 10 - %FS 11 - dBFS 12 - LSBs 13 - d% 14 - bits 15 - dBr Notes: (1) This control is valid only if the control 'meas mode' is set to: level select di, level even di, level odd di or level all di.
Cluster Frequency Range
DBL | freq limit low in Hz (100.0) (DBL) Sets the lower limit of the THD + Noise / SINAD measurement. Valid Range: analog analyzer 22kHz: 20.0 Hz to 21.93 kHz analog analyzer 110kHz: 128.0 Hz to (120.0 kHz - 62.5 Hz) digital analyzer: sample freq/2400 to sample freq * 0.45294 Default Value: 100.0 Hz
DBL | freq limit high in Hz (20000.0) (DBL) Sets the upper limit of the THD + Noise / SINAD measurement. Valid Range: analog analyzer 22kHz: freq limit low + 8.79 Hz to 21.93 kHz analog analyzer 110kHz: freq limit low + 62.5 Hz to 120.0 kHz digital analyzer: freq limit low + sample freq/5461.3 to sample freq * 117/256 Default Value: 20.0 kHz


RSUPL Config Analyzer Func Mod Dist

This VI enables and configures the Modulation Distortion measurement. This function is available in digital generator only with measurement mode set to audio data.
The following settings are available:
- channel unit
- dynamic mode

RSUPL Config Analyzer Func Mod Dist.vi

Boolean Meas Unit (dB:F) (TF)
Selects the measurement unit.

Valid Range:
F - dB
T - %

Default Value:
F - dB
Boolean Dynamic Mode (precision:F) (TF)
Determines the possible dynamic of the measurement result and thus the measurement rate.

Valid Range:
F - precision (default)
T - fast

Notes:
(1) This control is active only in analog analyzer.
(2) Precision - the measurement is performed with high dynamic and with the analog notch filter cut in; the measurement time increases.
(3) Fast - fast measurement with less dynamic.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Config Analyzer Func Diff Freq Dist

This VI enables and configures the Difference Frequency Distortion measurement. This function can be configured only in digital generator with measurement mode set to audio data.
The following settings are available:
- channel unit
- dynamic mode
- measurement mode

RSUPL Config Analyzer Func Diff Freq Dist.vi

Boolean Meas Unit (dB:F) (TF)
Selects the measurement unit.

Valid Range:
F - dB
T - %

Default Value:
F - dB
Boolean dynamic mode (precision:F) (TF)
Determines the possible dynamic of the measurement result and thus the measurement rate.

Valid Range:
F - precision (default)
T - fast

Notes:
(1) This control is active only in analog analyzer.
(2) Precision - the measurement is performed with high dynamic and with the analog notch filter cut in; the measurement time increases.
(3) Fast - fast measurement with less dynamic.
I32 meas mode (d2:0) (I32)
Selects the measurement mode and specifies the modulation products of the 2nd (d2) or 3rd (d3) order to be displayed.

Valid Range:
0 - d2 (IEC 268) (default)
1 - d2 (IEC 118)
2 - d3 (IEC 268)
3 - d3 (IEC 118)
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Valid Range: T: Error F: No Error (default)
I32 | code code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message. Valid Range: Not Applicable Default:0
String | source source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred. Default: Empty String
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Valid Range: T: Error F: No Error (default)
I32 | code code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message. Valid Range: Not Applicable Default:0
String | source source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred. Default: Empty String


RSUPL Config Analyzer Func Wow & Flutter

This VI enables and configures the Wow and Flutter measurement. The frequency deviation of a recording device is measured.
The following settins are available:
- mode
- weighting
- standard

RSUPL Config Analyzer Func Wow & Flutter.vi

Boolean weighting (off:F) (TF)
Enables or disables weighting filter.

Valid Range:
F - off (default)
T - on

Notes:
(1) With weighting on the weighting bandpass 4 Hz filter is used to weight the measurement.
I32 standard (DIN/IEC:0) (I32)
Selects the standard applied to the measurement.

Valid Range:
0 - DIN/IEC (default)
1 - NAB
2 - JIS
3 - 2 sigma 5s
4 - 2 sigma 10s

Notes:
(1) For more information concerning the above mentioned standards see the Operating Manual.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


RSUPL Config Analyzer Func Polarity

This VI configures the polarity test measurement.

Notes:
(1) The polarity measurement serves to check whether a device under test passes on an applied signal with the same polarity or with the reversed polarity.
(2) To perform the polarity measurement, set the polarity test signal generation on the generator (RSUPL Config Analyzer Func Polarity.vi) and activate polarity measurement with this function.

RSUPL Config Analyzer Func Polarity.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Config Analyzer Func FFT

This VI configures the FFT function of the analyzer. It transforms the unfiltered input signal into a frequency domain using fast fourier transform algorithm.
The following settings are available:
- center frequency
- unit of channel 1
- unit of channel 2
- fft size
- averaging mode
- averaging count
- zoom
- reference
- window
- beta factor
- notch gain
- notch frequency

Notes:
(1) Spectrum of a filtered input signal is possible by way of using post FFT processing of the function RMS & S/N (RSUPL Config Analyzer FFT.vi, RSUPL Config Analyzer Func RMS S/N.vi)

RSUPL Config Analyzer Func FFT.vi

I32 FFT Size (4096:4) (I32)
This control specifies the FFT size. The larger the FFT size (more calculated points) the better the frequency resolution, however the longer the measuring time.

Valid Range:
0 - 256
1 - 512
2 - 1024
3 - 2048
4 - 4096 (default)
5 - 8192
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Reference
I32 | reference (value:0) (I32) This control sets the reference source for relative measurements. Valid Range: 0 - value (default) 1 - store chan 1 2 - store chan 2 3 - store 4 - meas chan 1 5 - meas chan 2 6 - gen track Notes: (1) Use control 'reference value' to specify a reference value if this control is set to value (control value 0).
DBL | reference value (1.0) (DBL) This control sets the reference value for relative measurements. Valid Range: 0.0 to 1000.0 V Default Value: 1.0 Notes: (1) This control is active only if the control 'reference is set to value.
I32 | reference value unit (V:0) (I32) This control sets the reference value unit. Valid Range: 0 - V 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - W 7 - mW 8 - uW 9 - FS 10 - %FS 11 - dBFS 12 - LSBs 13 - d% 14 - bits 15 - dBr 16 - UI 17 - %UI 18 - dBUI 19 - ppm 20 - ns 21 - UIr
Cluster Averaging
I32 | averaging count (1) (I32) This control specifies the averaging count. Valid Range: 1 to 256 Default Value: 1
Boolean | averaging mode (exp:F) (TF) This control selects the averaging method in the FFT. Valid Range: F - exponential (default) T - normal Notes: (1) If normal is selected, a linear averaging is performed (an average value out of a specified number of FFTs is calculated). (2) In the exponential mode, the averaging is executed continuously. See the User's Manual for more information.
Cluster Measurement Units
I32 | unit chan 1 (V:0) (I32) This control specifies the channel unit of the channel 1. Valid Range: 0 - V (default) 1 - dBV 2 - dBu 3 - dBm 4 - W 5 - d%V 6 - dV 7 - V/Vr 8 - %V/Vr 9 - d%W 10 - dW 11 - P/Pr 12 - %P/Pr 13 - FS 14 - %FS 15 - dBFS 16 - LSBs 17 - d% 18 - bits 19 - dBr 20 - UI 21 - %UI 22 - dBUI 23 - ppm 24 - ns 25 - UIr
I32 | unit chan 2 (V:0) (I32) This control specifies the channel unit of the channel 2. Valid Range: 0 - V (default) 1 - dBV 2 - dBu 3 - dBm 4 - W 5 - d%V 6 - dV 7 - V/Vr 8 - %V/Vr 9 - d%W 10 - dW 11 - P/Pr 12 - %P/Pr 13 - FS 14 - %FS 15 - dBFS 16 - LSBs 17 - d% 18 - bits 19 - dBr 20 - UI 21 - %UI 22 - dBUI 23 - ppm 24 - ns 25 - UIr
Cluster Notch Filter
I32 | notch gain (off:0) (I32) This control selects the notch gain. Valid Range: 0 - off (default) 1 - 0 dB 2 - 12 dB auto 3 - 30 dB auto
Boolean | notch freq (value:F) (TF) This control selects the notch frequency mode. Valid Range: F - value (default) T - generator track
DBL | notch freq value in Hz (10.0) (DBL) This control selects the notch frequency value in Hz. Valid Range: 10.0 to 22500.0 Hz Default Value: 10.0 Hz Notes: (1) This controls has an effect only if the control 'notch freq' is set to value.
Cluster Window Function
I32 | window type (hanning:0) (I32) This control selects the windows function for FFT. Valid Range: 0 - hanning (default) 1 - rectangular 2 - blackmann-harris 3 - rife vinc 1 4 - rife vinc 2 5 - rife vinc 3 6 - hamming 7 - flat-top 8 - kaiser
DBL | beta factor (12.0) (DBL) This control specifies the beta factor of the kaiser window function. Valid Range: 1.0 to 20.0 Default Value: 12.0
Cluster Zooming
I32 | zoom (off:0) (I32) This control determines, whether the FFT is calculated from the entire frequency range or from a section only. Valid Range: 0 - off (default) 1 - 2 2 - 4 3 - 8 4 - 16 5 - 32 6 - 64 7 - 128
DBL | center freq in Hz (10000.0) (DBL) This control specifies the center frequency of the zoom window. Valid Range: 0.0 to 55000.0 Hz Default Value:10000.0 Hz


RSUPL Config Analyzer Func Waveform

This VI configures the time-domain acquisition and display of the input signal. The following settings are available:
- measurement mode
- compression factor
- interpolation
- channel unit
- trace length
- reference level
- filter selection
- trigger level
- trigger slope
- trigger source

Notes:
(1) In the slow instruments (Analog 22 kHz and digital), the two channel acquisition is performed simultaneously.
(2) In the fast (analog) analyzer, the two channel acquisition is performed sequentially, which is why no time reference between the two channels is specified.
(3) To select a filter for this measurement function, use the RSUPL Config Analyzer Filter Select VI.

RSUPL Config Analyzer Func Waveform.vi

I32 Meas Unit (V:0) (I32)
This control specifies the acquired waveform point values unit.

Valid Range:
0 - V (default)
1 - dBV
2 - dBu
3 - dBm
4 - W
5 - d%V
6 - dV
7 - V/Vr
8 - %V/Vr
9 - d%W
10 - dW
11 - P/Pr
12 - %P/Pr
13 - FS
14 - %FS
15 - dBFS
16 - LSBs
17 - d%
18 - bits
19 - dBr
20 - UI
21 - %UI
22 - dBUI
23 - ppm
24 - ns
25 - UIr
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Compression
I32 | Meas Mode (standard:0) (I32) Selects measurement mode, i.e. the way data are acquired and processed. Valid range: 0 - standard 1 - compressed 2 - undersample Default Value: 0 - standard Notes: (1) In A110 instrument, only 'standard' mode is available. (2) In 'standard' mode, the sample values are displayed without further processing. Maximum trace length is 7488 points; Interpolation is available. (3) In 'compressed' mode, only the highest absolute peak value out of a number of samples defined by Compression Factor is displayed. Thus, the display appears compressed on the x-axis. Maximum trace length is 7488 points; Interpolation is not available. (4) In 'undersample' mode, the arithmetic average of a number of samples defined by Compression Factor is calculated and displayed. This allows for recording over long time intervals. Interpolation is not available.
I32 | compression factor (2) (I32) This control specifies the compression factor for compressed mode measurements. Valid Range: 2 to 1024 Default Value: 2 Notes: (1) This control has no effect in standard measurement mode.
Cluster Reference
DBL | reference level (1.0) (DBL) This control specifies the reference level value for the relative measurements. Valid Range: -1000.0 to 1000.0 V Default Value: 1.0
I32 | reference level unit (V:0) (I32) This control sets the reference level unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - W 7 - mW 8 - uW 9 - FS 10 - %FS 11 - dBFS 12 - LSBs 13 - d% 14 - bits 15 - dBr 16 - UI 17 - %UI 18 - dBUI 19 - ppm 20 - ns 21 - UIr
Cluster Trigger
I32 | trigger source (channel 1:0) (I32) This control specifies the trigger source. Valid Range: 0 - channel 1 (default) 1 - channel 2 2 - generator track Notes: (1) This control is active only with analyzer set to analog 22kHz and digital. (2) If set to generator track, the generator triggers the measurement upon the beginning of the burst on phase, provided that a suitable generator function has been selected. This setting ensures that the measurement is started exactly synchronous with the generator burst.
Boolean | trigger slope (rising:T) (TF) This control sets the trigger slope of the waveform trigger. Valid Range: F - falling T - rising (default)
DBL | trigger level (0.0) (DBL) This control sets the trigger level value. Valid Range: digital (audio data mode): -1 FS to 1 FS digital (jitter mode) : -10 UI to 10 UI digital and analog common mode: -50 V to 50 V Default Value: 0.0
I32 | trigger level unit (V:0) (I32) This control sets the trigger level unit. Valid Range: 0 - V (default) 1 - mV 2 - uV 3 - dBV 4 - dBu 5 - dBm 6 - W 7 - mW 8 - uW 9 - FS 10 - %FS 11 - dBFS 12 - LSBs 13 - d% 14 - bits 15 - dBr 16 - UI 17 - %UI 18 - dBUI 19 - ppm 20 - ns 21 - UIr
Cluster Trace
I32 | interpolation (1:0) (I32) This control selects the number of interpolation steps used for the display of the traced waveform. Valid Range: 0 - 1 (default) 1 - 2 2 - 4 3 - 8 4 - 16 5 - 32 Notes: (1) Setting the interpolation factor to more than 1 (control value 0) causes switch-on of the interpolation algorithm. (2) This setting can be used to obtain a smoothed display in the case of few samples per period of the input signal. The maximum permissible trace length is however reduced with this setting. (3) Interpolation function is recommended with high frequencies, which allow for recording of few samples per period, only. (4) This control has no effect in compressed measurement mode.
DBL | trace length in s (0.01) (DBL) This control sets the trace length. The possible range depends on the sampling frequency, compression factor, interpolation value and the selected measurement mode. Valid Range: analog analyzer 22 kHz: 1 us to 155.98 ms 110 kHz: 1 us to 24.372 ms digital analyzer 27 kHz: 1 us to 277.3 ms 55 kHz: 1 us to 136.13 ms In the standard mode, the range limits are reduced by the interpolation factor. In the compressed mode, the range limits can be obtained by multiplying the above values by compression factor. Default Value: 0.01 sec Notes: (1) The memory depth is 7488 samples.
I32 Filter (off:0) (I32)
Selects a filter.

Valid Range:
0 - off (default)
1 - user 1
2 - user 2
3 - user 3
4 - user 4
5 - user 5
6 - user 6
7 - user 7
8 - user 8
9 - user 9
10 - A Weighting
11 - C Message
12 - CCITT
13 - CCIR wtd
14 - CCIR unwtd
15 - DEEM 50/15
16 - DEEMPH 50
17 - DEEMPH 75
18 - DEEMPH J.17
19 - RUMBLE wtd
20 - RUMBLE unw
21 - DC Noise HP
22 - CCIR ARM
23 - IEC Tuner
24 - Jitter wtd


RSUPL Config Analyzer Func Filt Sim

This VI configures the filter simulation function.
The following settings are available:
- unit

Notes:
(1) The filter simulation function is not used for measurements, but serves to check a selectable combination of filters or user-defined filters for their sum frequency response.
(2) Use VI RSUPL Config Analyzer Filter Sel.vi to select the filters to be simulated.

RSUPL Config Analyzer Func Filt Sim.vi

Boolean Meas Unit (dB:F) (TF)
This control selects the amplitude unit of the sum frequency response of the filters.

Valid Range:
F - dB
T - %

Default Value:
F - dB
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


RSUPL Config Analyzer Func Protocol

This VI configures the analysis and display of AES protocol data as well as measurement of the input peak and the sample frequency.

Notes:
(1) This function is available only in the digital analyzer with audio data mode.

RSUPL Config Analyzer Func Protocol.vi

Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


RSUPL Config Save Recall Setup

This VI saves or recalls instrument's setup.
The following settings are available:
- setup mode
- setup filename
- file attribute
- setup type

RSUPL Config Save Recall Setup.vi

Boolean setup mode (store:F) (TF)
Specifies whether an instrument setup will be stored or recalled.

Valid Range:
F - store (default)
T - load
String file name ("*.sac") (abc)
Specifies the file where the instrument setup will be stored.

Default Value: "*.sac"

Notes:
(1) Example: "C:\\UPL\\USER\\STP1.SAC"
(2) The file extention depends on the setup type:
- Complete Instrument Setup - "*.SCO"
- Current Instrument Setup - "*.SAC"
Boolean file attribute (read/write:F) (TF)
Sets the setup file attribute.

Valid Range:
F - read/write (default)
T - read only
Boolean setup type (current:F) (TF)
Defines the kind of setup to store.

Valid Range:
F - current (default)
T - complete
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Config Instr Ver

This VI returns the instrument version numbers.

RSUPL Config Instr Ver.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Hardware Versions
String | analog board version (abc) Returns the analog board version number.
String | cpu version (abc) Returns the CPU version number.
String | digital board version (abc) Returns the digital board version number.
Cluster Software Versions
String | software version (abc) Returns the UPL software version number.
String | setup version (abc) Returns the setup version number.


RSUPL Config Instr Opt

This VI returns the list of installed instrument options.

RSUPL Config Instr Opt.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Hardware Options
String | low distortion generator (abc) Returns the version number of the Low Distortion Generator (UPL-B1). Notes: (1) "-NA-" stands for "Option not available"; "INST" stands for "Option installed"
String | digital i/o (abc) Returns the version number of the Digital Audio I/O (UPL-B2). Notes: (1) "-NA-" stands for "Option not available"; "INST" stands for "Option installed"
String | audio monitor (abc) Returns the version number of the Audio Monitor (UPL-B5). Notes: (1) "-NA-" stands for "Option not available"; "INST" stands for "Option installed"
Cluster Software Options
String | remote control (abc) Returns the version number of the Remote Control (UPL-B4). Notes: (1) "-NA-" stands for "Option not available"; "INST" stands for "Option installed"
String | digital audio protocol (abc) Returns the version number of the Digital Audio Protocol (UPL-B21). Notes: (1) "-NA-" stands for "Option not available"; "INST" stands for "Option installed"
String | jitter and interface test (abc) Returns the version number of the Jitter And Phase Test (UPL-B22). Notes: (1) "-NA-" stands for "Option not available"; "INST" stands for "Option installed"
String | universal sequence controller (abc) Returns the version number of the Universal Sequence Controller (UPL-B10). Notes: (1) "-NA-" stands for "Option not available"; "INST" stands for "Option installed"


RSUPL Config Instr Trig

This VI configures the instrument's trigger.

RSUPL Config Instr Trig.vi

Boolean trigger mode (continuous:T) (TF)
Selects the way the instrument will be triggered.

Valid Range:
F - continuous (default)
T - single
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Config Instr Audio Monitor

This VI sets Audio Monitor Mode.
(Only available with option B5 installed.)

RSUPL Config Instr Audio Monitor.vi

Boolean speaker state (off:F) (TF)
Switches the internal speaker on or off.

Valid Range:
F - off (default)
T - on
I32 speaker source (off:0) (I32)
Selects the source for the speaker signal.

Valid Range:
0 - off (default)
1 - Input Ch 1
2 - Input Ch 2
3 - Input Ch 1&2 (stereo)
4 - Function Ch 1
5 - Function Ch 2
6 - Function Ch 1&2 (stereo)
7 - AES Input Ch 1
8 - AES Input Ch 2
9 - AES Input CH 1&2 (stereo)

Notes:
(1) The availability of the signal sources listed above depends on analyzer setup.
(2) In digital analyzer modes "Jitter/Phas" and "Common/Inp", only the settings "Off" and "Inp1" are valid.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Boolean phones mode (=speaker:F) (TF)
Selects headphone output mode.

Valid Range:
0 - =speaker (default)
1 - permanent
DBL speaker gain (0.0) (DBL)
Sets pre-gain of the speaker signal in dB.

Valid Range:
-120 to 120

Notes:
(1) This setting is only available in source modes "Function Ch 1/2/1&2".
DBL speaker volume (30.0) (DBL)
Sets speaker volume in percent of max volume.

Valid Range:
0 to 100


RSUPL Config Instr Calibr

This VI triggers the instrument to perform a self-calibration of selected components.
The following settings are available:
- calibration generator
- calibration analyzer
- digital calibration

RSUPL Config Instr Calibr.vi

Boolean calibration generator (off:F) (TF)
Selects the sort of generator calibration.

Valid Range:
F - off (default)
T - once
I32 calibration analyzer (off:0) (I32)
Selects the sort of analyzer calibration.

Valid Range:
0 - off
1 - once
2 - on (default)
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Boolean calibration digital (off:F) (TF)
Selects the sort of digital phase to reference measurement calibration.

Valid Range:
0 - off (default)
1 - once


RSUPL Config Instr Display

Turns on or off the instrument's numeric display; turns off cursors in the instrument's graph display.
Useful to increase measurement speed.

RSUPL Config Instr Display.vi

Boolean display (on:T) Turns on or of the instrument front panel display.

Valid Range:
F - off (default)
T - on

Notes:
(1) Turning off the display speeds up the operations.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Boolean cursors (don't change:T)


RSUPL Config Instr Sense

This VI is useful to switch off sense systems not needed, in order to increase measurement speed.

Use the appropriate Config Analyzer VI to reselect a sense mode.

RSUPL Config Instr Sense.vi

Boolean Sense1 (don't change: T) (TF)
Selects whether Sense System 1 is to be switched off or not.

Valid Range:
F - switch off
T - don't change (default)
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Boolean Sense2 (don't change: T) (TF)
Selects whether Sense System 2 is to be switched off or not.

Valid Range:
F - switch off
T - don't change (default)
Boolean Sense3 (don't change: T) (TF)
Selects whether Sense System 3 is to be switched off or not.

Valid Range:
F - switch off
T - don't change (default)


RSUPL Config Store Data

This VI configures the data storing capabality of the instrument. The specified data is stored to the instrument's hard or floppy drive.
The following settings are available:
- data type
- data format
- data filename
- normalizing frequency
- level source
- invert 1/n switch

RSUPL Config Store Data.vi

I32 data type (trace A:0) (I32)
This control specifies the data to store.

Valid Range:
0 - trace A (default)
1 - trace B
2 - trace A + B
3 - limit report
4 - dwell value
5 - upper limit
6 - lower limit
7 - X axis
8 - Y axis
9 - equalization
DBL normalizing freq in Hz (1000.0) (DBL)
Sets the reference frequency for the normalization of the equalization file.

Valid Range: 0.0 Hz to 125.0 kHz

Default Value: 1000.0 Hz

Notes:
(1) This control is active only if 'data type' is set to equalization.
String file name ("*.*") (abc)
Specifies the file where the data will be stored.

Default Value: "*.*"

Notes:
(1) Example: "C:\\UPL\\USER\\FILE1.TRC"
(2) The file extention depends on the data type:

- trace A, trace B, trace A + B, X axis, Y axis - "*.TRC"
- limit report - "*.ERR"
- dwell value - "*.DWL"
- upper limit - "*.LUP"
- lower limit - "*.LLW"
- equalization - "*.VEQ"
Boolean data format (ASCII:F) (TF)
Specifies the data format in which the data will be stored.

Valid Range:
F - ASCII (default)
T - real
Boolean level source (trace A:F) (TF)
Selects the trace used to create the equalization file.

Valid Range:
F - trace A (default)
T - trace B

Notes:
(1) This control is active only if 'data type' is set to equalization.
Boolean invert 1/n (off:F) (TF)
Specifies whether the equalization file will be stored in normal or inverted form.

Valid Range:
F - off (default)
T - on

Notes:
(1) This control is active only if 'data type' is set to equalization.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Set Freq & Level

This VI is useful for setting generator frequency and level, if a sweep measurement is to be controlled by a loop. See configuration functions for more details.

RSUPL Set Freq & Level.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
DBL frequency (50.0) (DBL)
This control sets the sinewave frequency.

Valid Range: 10.0 Hz to 110.0 kHz

Default Value: 50.0
DBL level (0.0) (DBL)
This control sets the amplitude of the output sinewave.

Valid Range:

digital: 0.0 to 1.0 FS (audio data mode)
0.0 to 5.0 UI (jitter mode)
0.0 to 7.071 Vrms (common mode)

analog: 0.0 to 10.0 Vrms for unbalanced output
0.0 to 20.0 Vrms for balanced output

Default Value: 0.0

Notes:
(1) Use RSUPL Config Gen Analog Setup.vi or RSUPL Config Gen Digital Setup.vi to set the level limit value.
I32 level unit (V:0) (I32)
This control sets the amplitude unit of the output sinewave.

Valid Range:

analog and digital common mode
0 - V (default)
1 - mV
2 - uV
3 - dBV
4 - dBu
5 - dBm
6 - V/Vr
7 - d%V
8 - dV
9 - dmV
10 - duV
11 - Vpp
12 - mVpp
13 - uVpp
14 - dBr

digital audio data mode
14 - dBr
15 - FS
16 - %FS
17 - dBFS
18 - LSBs
19 - d%
20 - bits

digital jitter mode
14 - dBr
21 - UI
22 - %UI
23 - dBUI
24 - ppm
25 - ns
26 - UIr
I32 freq unit (Hz:0) (I32)
This control sets the sinewave frequency unit.

Valid Range:
0 - Hz (default)
1 - kHz
2 - dHz
3 - dkHz
4 - f/fr
5 - d%Hz
6 - Toct
7 - Oct
8 - Dec
Boolean set frequency (off: F) (TF)
This control determines whether or not the current generator frequency is to be changed.

Valid Range:
F - don't set frequency (default)
T - set frequency
Boolean set level (off: F)


RSUPL Send Trig

This VI triggers an action.

RSUPL Send Trig.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Step

This VI triggers a step of a specified sweep. See configuration functions for more details.

Boolean direction (up:F) (TF)
Selects the direction of a step.

Valid Range:
F - up (default)
T - down
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Abort

This VI aborts an action.

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Operation Complete

This VI waits until all previous operations will have been completed.

RSUPL Operation Complete.vi

DBL max timeout in sec (180) (DBL)
Sets the timeout for this panel. When the previous operation doesn't seem to finish and the instrument is being polled for an infinite time, this is the way to stop it. But - when the instrument is timed-out it is necessary to reinitialize it again.

Valid Range: 0.0 s to 600.0 s

Default Value: 180.0 s
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Data Store Del

This VI deletes a file on the instrument's hard or floppy drive.

RSUPL Data Store Del.vi

String file name ("*.*") (abc)
Specifies the file.

Default Value: "*.*"

Notes:
(1) Example: "C:\\UPL\\USER\\FILE1.DAT"
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Data Store Copy

This VI copies one file on the instrument's hard or floppy drive to another.

RSUPL Data Store Copy.vi

String source file name (abc)
Specifies the source file.

Default Value: "*.*"

Notes:
(1) Example: "C:\\UPL\\USER\\FILE1.DAT"
String target file name (abc)
Specifies the target file.

Default Value: "*.*"

Notes:
(1) Example: "C:\\UPL\\USER\\FILE1.DAT"
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Data Store Dir

This VI selects the working directory.

RSUPL Data Store Dir.vi

String path (abc)
Specifies the path.

Notes:
(1) Example: "C:\\UPL\\USER"
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Data Read Block

This VI reads a block of data from the instrument and stores it into an array.

RSUPL Data Read Block.vi

I32 variable (frequency list:0) (I32)
Specifies the block of data.

Valid Range:
0 - frequency list (default)
1 - voltage list
2 - on-time list
3 - interval list
4 - dwell list
5 - equalization data - voltage
6 - equalization data - frequency
7 - Y axis upper limit data
8 - Y axis lower limit data
9 - X axis upper limit data
10 - X axis lower limit data
11 - 1. meas sequence data (Y1)
12 - 2. meas sequence data (Y2)
13 - sweep list (X)
14 - sweep list (Z)
15 - reference data (Z)
16 - reference data (Y)
17 - reference data (X axis of A)
18 - reference data (X axis of B)
19 - limit report data
Array block data (DBL)
Specifies the block data array.
SGL
I32 number of values read (I32)
Returns the number of values that were read from the instrument.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Data Write Block

This function waits until all previous operations will have been completed.

RSUPL Data Write Block.vi

Array block data (DBL)
Specifies the block data array.
SGL
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
I32 variable (frequency list:0) (I32)
Specifies the block of data.

Valid Range:
0 - frequency list (default)
1 - voltage list
2 - on-time list
3 - interval list
4 - dwell list
5 - equalization data - voltage
6 - equalization data - frequency
7 - Y axis upper limit data
8 - Y axis lower limit data
9 - X axis upper limit data
10 - X axis lower limit data
11 - 1. meas sequence data (Y1)
12 - 2. meas sequence data (Y2)
13 - sweep list (X)
14 - sweep list (Z)
15 - reference data (Z)
16 - reference data (Y)
17 - reference data (X axis of A)
18 - reference data (X axis of B)
19 - limit report data


RSUPL Meas Single Ch

This VI reads a measurement from the instrument.
The following settings are available:
- channel
- variable

RSUPL Meas Single Ch.vi

Boolean channel (1:F) (TF)
Selects the channel.

Valid Range:
F - 1 (default)
T - 2
I32 variable (1st analyzer:0) (I32)
Selects the variable to read.

Valid Range:
0 - 1st analyzer (default)
1 - 2nd analyzer, peak voltage meter
2 - 3rd analyzer, frequency counter
3 - 4rd analyzer, phase meter
DBL measured value (DBL)
Returns measured value read from the instrument.

Notes:
(1) If no measurement was taken, NAN (9.93E+37) is returned.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Meas Dual Ch

This VI subsequently reads two measurements from channel 1 and channel 2 of the same analyzer instrument.
The following settings are available:
- variable (analyzer)

RSUPL Meas Dual Ch.vi

I32 variable (1st analyzer:0) (I32)
Selects the variable to read.

Valid Range:
0 - 1st analyzer (default)
1 - 2nd analyzer, peak voltage meter
2 - 3rd analyzer, frequency counter
DBL measured value Ch1 (DBL)
Returns measured value read from channel 1 of the instrument.

Notes:
(1) If no measurement was taken, NAN (9.93E+37) is returned.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
DBL measured value Ch2 (DBL)
Returns measured value read from channel 2 of the instrument.

Notes:
(1) If no measurement was taken, NAN (9.93E+37) is returned.


RSUPL Meas Protocol

This VI returns results of protocol analysis.

RSUPL Meas Protocol.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Status
String | channel status (abc) Indicates changes in the channel status data.
String | l&r channel data (abc) Indicates if the status data between left and right channel are equal or different.
String | validity bit (left) (abc) Indicates the position of the validity bit in the left channel.
String | validity bit (right) (abc) Indicates the position of the validity bit in the right channel.
Cluster Errors
String | general errors (abc) Returns errors occured.
I32 | parity errors (I32) Displays the sum of all occured parity errors.
I32 | crc errors (left) (abc) Returns number of internal CRC errors in the left channel.
I32 | crc errors (right) (abc) Returns number of internal CRC errors in the right channel.


RSUPL Meas Limit

This VI returns 1 when a limit is exceeded, otherwise 0. See VI RSUPL Config Analyzer Limit.vi for more information.

RSUPL Meas Limit.vi

Boolean Limit Failure (TF)
Returns limit check status, T=out of limit, F=limit not exceeded.
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Reset

This VI resets the instrument. Consult the user's manual for the default parameter settings to which this command resets the instrument.

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Self Test

This VI causes the instrument to perform a self-test and returns the results. The boolean indicates if the instrument passed self-test.

RSUPL Self Test.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Boolean test


RSUPL Error Query

This VI reads an error from the instrument. It expects to see errors in SCPI format (#,"error message"). If an error query is not supported, it returns a warning.

RSUPL Error Query.vi

String Error Message Message describing the instrument's error.
I32 Error Indicates the error number of the error returned.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (cross) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning reported. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning reported. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (cross) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning reported. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning reported. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL Error Message

This VI contains all the intrument specific error codes and descriptions. Use this VI after executing several instrument driver VIs to recognize and display any errors that may have occurred.

RSUPL Error Message.vi

String | error message Description of any error that occurred
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Boolean | status (bool) status: TRUE if an error has occurred.
I32 | code (i32) code: the error code associated with an error. A value of 0 means no error, a negative value is an error, and a positive value is a warning.
Array user-defined codes User-defined error codes. Each code correspondes to an error message stored at the same index in user-defined descriptions.
I32
Array user-defined descriptions User-defined error descriptions. Each description correspondes to an error number stored at the same index in user-defined codes.
String
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
I32 | type of dialog (OK msg:1) This selects the style of dialog to display when an error occurs. 0: no dialog at all, 1: a dialog with an OK button, or 2: a dialog with a Continue and Stop button.


RSUPL Revision Query

This VI queries the current instrument firmware revision and instrument driver revision. This Instrument Driver's Revision number is "Rev 3.1.2, 11/2007, LV 6.1".

Rohde & Schwarz UPL DC - 110kHz Audio Analyzer
Created By: Jan Sima
VSB - TU Ostrava
Czech Republic
e-mail: Jan.Sima@vsb.cz
Release Date: March 1997
Originally Developed in LabVIEW Version: 4.0

Instrument Diver Revision: 3.1.1

Modification History:

----- Rev. 2.0, April 1998 by Tobias Hermann 1GP2, Rohde & Schwarz Munich -----

* General changes/corrections:
- Reference Level must not be zero - changed default value in all affected VIs

* Bugfixes:
- Cfg Gen Func Sine VI
A25 Generator: issue equalizer file load command only if "Equalization" == "on" (added Case Structure)
- Cfg Analyzer Analog Setup VI
added synchronisation command after instrument selection (wait for analyzer offset calibration)
- Cfg Analyzer Trig VI
renamed Start Condition 9/10 to "Freq Fast Ch1/2" (changed Front Panel and Description)
- Cfg Analyzer Func RMS S/N VI, Cfg Analyzer Func FFT VI
issue notch filter freq "FIX" command only if "Notch Gain" <> "off" (added Case Structure)
- Cfg Analyzer Func Peak VI, Cfg Analyzer Func W+F VI
added cases A22/A110 (Peak/W+F not supported in A110)
- Cfg Analyzer Func QPeak VI
issue notch filter freq "FIX" command only if "Notch Gain" <> "off" (added Case Structure)
added cases A22/A110 (QPeak not supported in A110)
- Cfg Analyzer Meas Inp Freq VI
added cases A22/D48 (e.g. no Sample Frequency measurement in A22 instrument)
- Data Read Block VI
read 4n+1 bytes, process 4n bytes (UPL terminates data blocks with <EOI> + <LF>)
added VISA error status check (errors in previous VIs appeared as Block Data Errors)
- Application Example VI
changed to universal analog generator (to make it run on models without option UPL-B2)
removed trigger VIs (not necessary for generator functions)

* Additions:
- Get Analyzer Mode VI
added query A22/A110 and "instr mode" output (for Cfg Analyzer Func Peak/QPeak/W+F VIs)
- Config Instr Display
added control for disabling the cursor readout in the instrument's graphic display (enhances measurement speed)

* deleted VIs:
- Screen Hardcopy is no longer supported by the driver (not of much use in remote mode)

* new VIs:
- Meas Dual Channel VI [Data VIs]
Reads the results from both channels at once (added for better consistency of the driver concept)
- Set Freq & Level VI [Action VIs]
Directly accesses the generator's frequency and/or level controls without overhead (useful for fast measurement loops controlled from LabVIEW)
- Config Instr Audio Monitor VI [Config Instrument VIs]
Configures the instrument's Audio Monitor (Option UPL-B6)
- Config Instr Sense [Config Instrument VIs]
Allows for disabling the instrument's sense systems 1 (Analyzer Function), 2 (Input Level) and 3 (Input Frequency) (enhances measurement speed)

----- Rev. 3.0, August 1999 by Tobias Hermann 1GPP, Rohde & Schwarz Munich -----

* General changes/corrections:
- cluster inputs in all VIs with more than 6 inputs
- connector panes: 5x5 type
- improved code of Get* VIs (now in RSUPL_U.llb)
- improved code of Data Read Block VI

* Bugfixes:
- Config Gen Sweep Setup
fixed bugs preventing user from loading x and z axis sweep list files
- Config Analyzer Func DFD/Mod Dist/THD/THD+N/W+F/Waveform/Filt Sim VIs
fixed bug issuing wrong UNIT command when only CH2 active in analyzer
- Config Analyzer Func RMS/Peak/QPeak VIs
fixed bug erroneously issuing UNIT commands in S/N Sequence mode

* Additions:
- none -:

* deleted VIs:
- none -

* new VIs:
- none -

----- Rev. 3.1, May 2004 by Jiri Kominek -----

* General changes/corrections:
- renamed VIs with '/' in the name:
- RSUPL Config Save/Recall Setup.vi to RSUPL Config Save Recall Setup.vi
- RSUPL Config Analyzer Func RMS S/N.vi to RSUPL Config Analyzer Func RMS S N.vi

* Bugfixes:
- none -

* Additions:
- none -

* deleted VIs:
- none -

* new VIs:
- none -

----- Rev. 3.1.1, August 2005 by Jiri Kominek -----

* General changes/corrections:
- Fixed palette menu

* Bugfixes:
- RSUPL Error Query.vi
- RSUPL Error Query (Multiple).vi

* Additions:
- none -

* deleted VIs:
- none -

* new VIs:
- none -

RSUPL Revision Query.vi

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
String | instr firmware revision This indicates the revision of the instruments firmware. This version and its capabilities are controlled by the instrument manufacturer. This instrument driver was developed using instrument with firmware version 0.29.
String | instr driver revision This indicates the revision of this instrument driver software.


RSUPL Close

This function performs the following operations:
viClose (instrSession) and viClose (rmSession).

Notes:

(1) The instrument must be reinitialized to use it again.

Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable


Alphabetical list of VIs

This page shows alphabetical list of all VIs.

RSUPL Abort.vi
RSUPL Application Example.vi
RSUPL Close.vi
RSUPL Config Analyzer Analog Setup.vi
RSUPL Config Analyzer Digital Setup.vi
RSUPL Config Analyzer Filter Sel.vi
RSUPL Config Analyzer Filter User.vi
RSUPL Config Analyzer Func DC.vi
RSUPL Config Analyzer Func Diff Freq Dist.vi
RSUPL Config Analyzer Func FFT.vi
RSUPL Config Analyzer Func Filt Sim.vi
RSUPL Config Analyzer Func Mod Dist.vi
RSUPL Config Analyzer Func Peak.vi
RSUPL Config Analyzer Func Polarity.vi
RSUPL Config Analyzer Func Protocol.vi
RSUPL Config Analyzer Func Quasi Peak.vi
RSUPL Config Analyzer Func RMS S N.vi
RSUPL Config Analyzer Func RMS Sel.vi
RSUPL Config Analyzer Func RMS Sweep.vi
RSUPL Config Analyzer Func THD.vi
RSUPL Config Analyzer Func THD + Noise.vi
RSUPL Config Analyzer Func Waveform.vi
RSUPL Config Analyzer Func Wow & Flutter.vi
RSUPL Config Analyzer Limit.vi
RSUPL Config Analyzer Meas Inp Freq.vi
RSUPL Config Analyzer Meas Inp Volt.vi
RSUPL Config Analyzer Post FFT.vi
RSUPL Config Analyzer Protocol Anl.vi
RSUPL Config Analyzer Settl.vi
RSUPL Config Analyzer Trig.vi
RSUPL Config Gen Analog Setup.vi
RSUPL Config Gen Digital Protocol.vi
RSUPL Config Gen Digital Setup.vi
RSUPL Config Gen Digital Sync.vi
RSUPL Config Gen Func Arbitrary.vi
RSUPL Config Gen Func Burst.vi
RSUPL Config Gen Func Burst 2.vi
RSUPL Config Gen Func Diff Freq Distortion.vi
RSUPL Config Gen Func Modul Distortion.vi
RSUPL Config Gen Func Multi.vi
RSUPL Config Gen Func Polarity.vi
RSUPL Config Gen Func Random.vi
RSUPL Config Gen Func Sine.vi
RSUPL Config Gen Sweep Freq.vi
RSUPL Config Gen Sweep Interval.vi
RSUPL Config Gen Sweep Level.vi
RSUPL Config Gen Sweep On Time.vi
RSUPL Config Gen Sweep Setup.vi
RSUPL Config Instr Audio Monitor.vi
RSUPL Config Instr Calibr.vi
RSUPL Config Instr Display.vi
RSUPL Config Instr Opt.vi
RSUPL Config Instr Sense.vi
RSUPL Config Instr Trig.vi
RSUPL Config Instr Ver.vi
RSUPL Config Save Recall Setup.vi
RSUPL Config Store Data.vi
RSUPL Data Read Block.vi
RSUPL Data Store Copy.vi
RSUPL Data Store Del.vi
RSUPL Data Store Dir.vi
RSUPL Data Write Block.vi
RSUPL Error Message.vi
RSUPL Error Query.vi
RSUPL Error Query (Multiple).vi
RSUPL Get Analyzer Active Channels.vi
RSUPL Get Analyzer Mode.vi
RSUPL Get Generator Mode.vi
RSUPL Getting Started.vi
RSUPL Initialize.vi
RSUPL Meas Dual Ch.vi
RSUPL Meas Limit.vi
RSUPL Meas Protocol.vi
RSUPL Meas Single Ch.vi
RSUPL Operation Complete.vi
RSUPL Reset.vi
RSUPL Revision Query.vi
RSUPL Self Test.vi
RSUPL Send Trig.vi
RSUPL Set Freq & Level.vi
RSUPL Step.vi
RSUPL Utility Clean Up Initialize.vi
RSUPL Utility Default Instrument Setup.vi
RSUPL VI Tree.vi
convertor61.vi


Contact

Contact your Rohde & Schwarz Partners

For comprehensive information about Rohde and Schwarz, please visit our Rohde & Schwarz Homepage.

For queries regarding technical aspects of our products, please contact our Customer Support.

For international services, please contact our Service Partners.

For information on training and seminars, please visit our Training Center.

For latest instrument driver updates, please see our Rohde & Schwarz Drivers.

More Information...

For additional questions, please contact our headquarters in Munich:

ROHDE & SCHWARZ GmbH & Co. KG
Mühldorfstra-e 15
D-81671 München
Phone: +49 (89) 41 29 - 0
Fax: +49 (89) 41 29 12 164


Installing

After installing the driver the help file is located in the same directory as the instrument driver. You can either use the help as a standalone application or can call it from LabVIEW (versions 6.0 and newer). To work correctly as LabVIEW context help 'PREFIX.chm' has to be placed in the same directory as file 'PREFIX.llb'. The easiest way is always to copy the help file together with the driver.

How to use this help

  • LabVIEW 6.1
    If Context Help is shown (by pressing Ctrl+H) user can use the link 'Click here for more help' in every driver's VI to show this help. The page respective to VI from which the help was called will be shown.
  • LabVIEW 6.0
    If Context Help is shown (by pressing Ctrl+H) user can use the link 'Click here for more help' in every driver's VI to show this help. The Welcome page always will be shown.
  • LabVIEW 5.x and earlier
    Earlier versions of LabVIEW can't work with html help files so the only way to use this help is to open it from Windows by double clicking on the PREFIX.chm file. Help file will be opened with the Welcome page opened.


JavaScript Disabled

The HTML file you are trying to access uses JavaScript.

Windows If you are viewing the file from your computer or from a CD and you have Internet Explorer 4.0 or later installed, JavaScript is enabled by default. If you are viewing the file from a network, such as on an intranet or on the Web, or if you do not have Internet Explorer 4.0 or later installed, you must enable JavaScript to view the file. To enable JavaScript, click the Options button in the toolbar and select Internet Options from the shortcut menu.

Macintosh and UNIX Your browser does not support JavaScript, or you have disabled JavaScript. If your browser does not support JavaScript, install a recent browser version that does support JavaScript. To enable JavaScript in Internet Explorer or Netscape, select Edit»Preferences.


RSUPL Config Analyzer Meas Inp Freq

This VI configures the frequency, phase, and group delay measurement and display.
The following settings are available:
- display
- unit channel 1
- unit channel 2
- frequency reference
- phase reference

RSUPL Config Analyzer Meas Inp Freq.vi

I32 display (freq:1) (I32)
Enables the display and selects a variable to display.

Valid Range:
0 - off
1 - frequency (default)
2 - frequency & phase
3 - frequency & group delay
4 - sample frequency

Notes:
(1) Frequency - frequency measurement on both channels.
(2) Frequency & Phase - frequency measurement on channel 1, phase measurement between channels 2 and 1.
(3) Frequency & Group Delay - frequency measurement on channel 2, group delay measurement between channels 2 and 1.
(4) Sample Frequency - measurement of sampling frequency (available only in Digital Analyzer).
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Frequency Reference
I32 freq reference (value:0) (I32)
Sets the reference value for the frequency measurement.

Valid Range:
0 - value (default)
1 - store channel 1
2 - store channel 2
3 - store
4 - measure channel 1
5 - measure channel 2
6 - generator track

Notes:
(1) Value - the reference value is specified by control Frequency Reference Value
(2) Store Channel 1, 2 - the current frequency measurement result of channel 1 or 2 is stored when running this function and set as a new reference value. This selections are available only with two-channel measurement.
(3) Store - the result of a one-channel frequency measurement or a combined frequency & phase or frequency & group delay measurement is stored when running this function. The reference value does not change during the measurement. This selection is available only with one-channel measurement.
(4) Measure Channel 1, 2 - each measurement result of channel 1 or 2 is immediately stored as the reference value. This selections are available only with two-channel measurement.
(5) Generator Track - the presently valid generator frequency and each newly set generator frequency are stored as the reference value.
DBL ref value in Hz (0.001) (DBL)
Sets the reference frequency value.

Valid Range: 1.0 mHz to 1.0 MHz

Default Value: 0.001 Hz

Notes:
(1) This control is active only if Frequency Reference is set to Value.
Cluster Measurement Units
I32 | unit 1 (Hz:0) (I32) Selects the display unit of channel 1. Valid Range: 0 - Hz (default) 1 - dHz 2 - d%Hz 3 - Toct 4 - Oct 5 - Dec 6 - f/fr
I32 | unit 2 (Hz:0) (I32) Selects the display unit of channel 1. Valid Range: 0 - Hz (default) 1 - dHz 2 - d%Hz 3 - Toct 4 - Oct 5 - Dec 6 - f/fr
Cluster Phase Reference
Boolean | phase reference (value:F) (TF) Sets the reference value for the frequency measurement. Valid Range: F - value (default) T - store Notes: (1) Value - the reference value is specified by control Phase Reference Value. (2) Store - the current result of phase or group-delay measurement result is stored when running this function and set as a new reference value.
DBL | reference value (0.0) (DBL) Sets the phase frequency value. Valid Range: -360.0 deg to 360.0 deg -2PI rad to 2PI rad -10.0 s to 10.0 s Default Value: 0.0 deg Notes: (1) This control is active only if Phase Reference is set to Value.
I32 | Phase Unit (deg:0) (I32) Selects the phase unit. Valid Range: 0 - deg (default) 1 - rad 2 - s 3 - ms 4 - us 5 - min
I32 phase format (0..360:0) (I32)
Sets the display range of phase measurement.

Valid Range:
0 - 0..360 deg (default)
1 - -180..180 deg
2 - -360..0 deg
3 - 0..2PI
4 - -PI..PI
5 - -2PI..0


RSUPL Config Analyzer Meas Inp Volt

This VI configures the peak values measurement and display.
The following settings are available:
- display
- unit chan 1
- unit chan 2
- reference

RSUPL Config Analyzer Meas Inp Volt.vi

I32 display (peak:1) (I32)
Enables the display and selects a variable to display.

Valid Range:
0 - off
1 - peak (default)
2 - RMS
3 - phase to reference
4 - digital input amplitude

Notes:
(1) Phase To Reference - displays the frame phase of the jittered signal between AUDIO and REF input (available in Digital Analyzer - Measurement Mode Jitter/Phase).
(2) Digital Input Amplitude - displays the amplitude of digital input (available in Digital Analyzer - Measurement Mode Common/Input).
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster Measurement Units
I32 | unit chan 1 (V:0) (I32) Selects the display unit of channel 1. Valid Range: 0 - V (default) 1 - dBV 2 - dBu 3 - dBm 4 - W 5 - d%V 6 - dV 7 - V/Vr 8 - %V/Vr 9 - d%W 10 - dW 11 - P/Pr 12 - %P/Pr 13 - dBr 14 - FS 15 - %FS 16 - dBFS 17 - LSBs 18 - d% 19 - bits 20 - hex 21 - UI 22 - %UI 23 - ppm 24 - ns 25 - UIr 26 - dBUI 27 - %FRM 28 - degFRM
I32 | unit chan 2 (V:0) (I32) Selects the display unit of channel 2. Valid Range: 0 - V (default) 1 - dBV 2 - dBu 3 - dBm 4 - W 5 - d%V 6 - dV 7 - V/Vr 8 - %V/Vr 9 - d%W 10 - dW 11 - P/Pr 12 - %P/Pr 13 - dBr 14 - FS 15 - %FS 16 - dBFS 17 - LSBs 18 - d% 19 - bits 20 - hex
Cluster Reference
I32 reference (value:0) (I32)
Sets the reference value for the input measurement.

Valid Range:
0 - value (default)
1 - store channel 1
2 - store channel 2
3 - store
4 - measure channel 1
5 - measure channel 2
6 - generator track

Notes:
(1) Value - the reference value is specified by control Reference Value.
(2) Store Channel 1, 2 - the current level measurement result of channel 1 or 2 is stored when running this function and set as a new reference value. This selections are available only with two-channel measurement.
(3) Store - the result of a one-channel measurement is stored when running this function. The reference value does not change during the measurement. This selection is available only with one-channel measurement.
(4) Measure Channel 1, 2 - each measurement result of channel 1 or 2 is immediately stored as the reference value. This selections are available only with two-channel measurement.
(5) Generator Track - the presently valid generator voltage and each newly set generator voltage are stored as the reference value.
DBL reference value (1.0) (DBL)
Sets the reference value.

Valid Range:
-100.0 FS to 100.0 FS
-1000.0 V to 1000.0 V

Default Value: 1.0 V

Notes:
(1) This control is active only if Reference is set to Value.
I32 reference value unit (V:0) (I32)
Sets the reference value unit.

Valid Range:
0 - V (default)
1 - mV
2 - uV
3 - dBV
4 - dBu
5 - dBm
6 - W
7 - mW
8 - uW
9 - FS
10 - %FS
11 - dBFS
12 - LSBs
13 - d%
14 - bits
15 - dBr
16 - UI
17 - %UI
18 - dBUI
19 - ppm
20 - ns
21 - UIr

Notes:
(1) This control is active only if Reference is set to Value.


RSUPL Error Query (Multiple)

This VI reads the error queue from the instrument. It expects to see errors in SCPI format (#,"error message"). It continues to read from the error queue until it reads a 0, "No error". If the instrument does not support an error query, a warning is returned.

RSUPL Error Query (Multiple).vi

String Error Message Message describing all the errors in the instrument's error queue.

Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (cross) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning reported. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning reported. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (cross) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning reported. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning reported. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram's structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Array Error This is the index into the array of error numbers returned from the instrument's error queue.
I32 Error Returns the array of error numbers that were stored in the instrument's error queue.


RSUPL Get Analyzer Active Channels

This VI queries the currently active analyzer channels from the instrument.
For internal use only.

active chans:
-1 - ERROR
0 - n.a.
1 - ch1
2 - ch2
3 - both

RSUPL Get Analyzer Active Channels.vi

Refnum | VISA session
Refnum | dup VISA session
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I16 active chans -1 - ERROR
0 - n.a.
1 - ch1
2 - ch2
3 - both


RSUPL Get Analyzer Mode

This VI queries the current analyzer mode from the instrument.
For internal use only.

instr type:
F - analog
T - digital

instr mode:
0 - n.a.
1 - a22
2 - a110
3 - n.a.
4 - d48

dig mode:
-1 - ERROR
0 - audio data
1 - jitter/phase
2 - common/input

RSUPL Get Analyzer Mode.vi

Refnum | VISA session
Refnum | dup VISA session
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Boolean instr type F - analog
T - digital
I16 dig mode 0 - audio data
1 - jitter/phase
2 - common/input
U16 instr mode 0 - n.a.
1 - a22
2 - a110
3 - n.a.
4 - d48


RSUPL Get Generator Mode

This VI queries generator instrument type and digital source mode.
For internal use only.

Instr Type:
F - A25
T - D48

Dig Src Mode:
F - jitter/phase/common
T - audio data (default with A25)

RSUPL Get Generator Mode.vi

Refnum | VISA session
Cluster error in (no error)
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum | dup VISA session
Boolean Dig Src Mode (TF)

F - jitter/phase/common
T - audio data

Instr Type <> D48 -> Src Mode = T
Boolean Instr Type (TF)

F - A25
T - D48


RSUPL Utility Clean Up Initialize

This Utility VI closes any open VISA sessions in the event that there is an error during an initialization. It is called only from the PREFIX Initialize VI, and is not meant to be altered. Changing this VI can cause the PREFIX Initialize VI to operate improperly.

RSUPL Utility Clean Up Initialize

Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram’s structure.

Valid Range:
Not Applicable

Default:
Not Applicable
Refnum VISA session (for class)


RSUPL Utility Default Instrument Setup

This Utility VI sends a default command string to the instrument whenever a new VISA session is opened, or the instrument is reset. This VI is intended to be used as a subVI for the PREFIX Initialize and PREFIX Reset VI's. Altering this VI could cause these two VI's to operate incorrectly.

RSUPL Utility Default Instrument Setup

Refnum VISA session A unique reference to an instrument I/O session. It identifies which device to communicate with and all configuration information to perform the I/O. See the initialize VI for more information.

Valid Range:
Not Applicable

Default:
Not Applicable
Cluster error in (no error) error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Cluster error out error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

Valid Range:
Not Applicable

Default:
status= False (no error)
code = 0
source = empty string
Boolean | status The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
I32 | code The code input identifies the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
String | source The source string describes the origin of the error or warning. The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Refnum dup VISA session This is a copy of the VISA session. It is used programmatically to pass the VISA Session to any calling VIs. It simplifies dataflow programming by providing an easy method of chaining VIs together, thereby simplifying the diagram’s structure.

Valid Range:
Not Applicable

Default:
Not Applicable


RSUPL VI Tree

This VI's diagram contents displays the logical structure of this instrument driver. This Instrument Driver's Revision number is "Rev 3.1.2, 11/2007, LV 6.1".

Rohde & Schwarz UPL DC - 110kHz Audio Analyzer
Created By: Jan Sima
VSB - TU Ostrava
Czech Republic
e-mail: Jan.Sima@vsb.cz
Release Date: March 1997
Originally Developed in LabVIEW Version: 4.0

Modification History:

----- Rev. 2.0, April 1998 by Tobias Hermann 1GP2, Rohde & Schwarz Munich -----

* General changes/corrections:
- Reference Level must not be zero - changed default value in all affected VIs

* Bugfixes:
- Cfg Gen Func Sine VI
A25 Generator: issue equalizer file load command only if "Equalization" == "on" (added Case Structure)
- Cfg Analyzer Analog Setup VI
added synchronisation command after instrument selection (wait for analyzer offset calibration)
- Cfg Analyzer Trig VI
renamed Start Condition 9/10 to "Freq Fast Ch1/2" (changed Front Panel and Description)
- Cfg Analyzer Func RMS S/N VI, Cfg Analyzer Func FFT VI
issue notch filter freq "FIX" command only if "Notch Gain" <> "off" (added Case Structure)
- Cfg Analyzer Func Peak VI, Cfg Analyzer Func W+F VI
added cases A22/A110 (Peak/W+F not supported in A110)
- Cfg Analyzer Func QPeak VI
issue notch filter freq "FIX" command only if "Notch Gain" <> "off" (added Case Structure)
added cases A22/A110 (QPeak not supported in A110)
- Cfg Analyzer Meas Inp Freq VI
added cases A22/D48 (e.g. no Sample Frequency measurement in A22 instrument)
- Data Read Block VI
read 4n+1 bytes, process 4n bytes (UPL terminates data blocks with <EOI> + <LF>)
added VISA error status check (errors in previous VIs appeared as Block Data Errors)
- Application Example VI
changed to universal analog generator (to make it run on models without option UPL-B2)
removed trigger VIs (not necessary for generator functions)

* Additions:
- Get Analyzer Mode VI
added query A22/A110 and "instr mode" output (for Cfg Analyzer Func Peak/QPeak/W+F VIs)
- Config Instr Display
added control for disabling the cursor readout in the instrument's graphic display (enhances measurement speed)

* deleted VIs:
- Screen Hardcopy is no longer supported by the driver (not of much use in remote mode)

* new VIs:
- Meas Dual Channel VI [Data VIs]
Reads the results from both channels at once (added for better consistency of the driver concept)
- Set Freq & Level VI [Action VIs]
Directly accesses the generator's frequency and/or level controls without overhead (useful for fast measurement loops controlled from LabVIEW)
- Config Instr Audio Monitor VI [Config Instrument VIs]
Configures the instrument's Audio Monitor (Option UPL-B6)
- Config Instr Sense [Config Instrument VIs]
Allows for disabling the instrument's sense systems 1 (Analyzer Function), 2 (Input Level) and 3 (Input Frequency) (enhances measurement speed)

----- Rev. 3.0, August 1999 by Tobias Hermann 1GPP, Rohde & Schwarz Munich -----

* General changes/corrections:
- cluster inputs in all VIs with more than 6 inputs
- connector panes: 5x5 type
- improved code of Get* VIs (now in RSUPL_U.llb)
- improved code of Data Read Block VI

* Bugfixes:
- Config Gen Sweep Setup
fixed bugs preventing user from loading x and z axis sweep list files
- Config Analyzer Func DFD/Mod Dist/THD/THD+N/W+F/Waveform/Filt Sim VIs
fixed bug issuing wrong UNIT command when only CH2 active in analyzer
- Config Analyzer Func RMS/Peak/QPeak VIs
fixed bug erroneously issuing UNIT commands in S/N Sequence mode

* Additions:
- none -

* deleted VIs:
- none -

* new VIs:
- none -

----- Rev. 3.1, May 2004 by Jiri Kominek -----

* General changes/corrections:
- renamed VIs with '/' in the name:
- RSUPL Config Save/Recall Setup.vi to RSUPL Config Save Recall Setup.vi
- RSUPL Config Analyzer Func RMS S/N.vi to RSUPL Config Analyzer Func RMS S N.vi

* Bugfixes:
- none -

* Additions:
- none -

* deleted VIs:
- none -

* new VIs:
- none -

----- Rev. 3.1.1, August 2005 by Jiri Kominek -----

* General changes/corrections:
- Fixed palette menu

* Bugfixes:
- RSUPL Error Query.vi
- RSUPL Error Query (Multiple).vi

* Additions:
- none -

* deleted VIs:
- none -

* new VIs:
- none -

RSUPL VI Tree.vi